Bug 13047 - MonoIOStat tests fail in LinkSDKRegression test
Summary: MonoIOStat tests fail in LinkSDKRegression test
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Pre-release ()
Version: 6.3.x
Hardware: PC Mac OS
: --- normal
Target Milestone: 6.4 (async)
Assignee: Sebastien Pouliot
URL:
Depends on:
Blocks:
 
Reported: 2013-07-03 18:29 UTC by GouriKumari
Modified: 2013-07-08 12:34 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
LinkSDK_Verified logs (3.45 KB, application/octet-stream)
2013-07-08 12:30 UTC, GouriKumari
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Comment 1 Sebastien Pouliot 2013-07-03 21:50:58 UTC
Out of curiosity: Is that recent ? does it happens on many devices or a single one ?

I had this issue on one of my devices (and it's not recent) but could not duplicating it on others. In any case it's a bad test case (the io-layer, bug 6118, is not yet fixed). I'll fix the test.
Comment 3 Sebastien Pouliot 2013-07-04 17:33:46 UTC
Fixed in cfcd4ad8cf278e29fc9f4c25c26eeb278cd0985b
The test should not fail anymore for any device.
Comment 4 Saurabh 2013-07-08 12:08:33 UTC
Please provide us any testcase or attached sample, so that we can verify this issue.
Comment 5 GouriKumari 2013-07-08 12:30:21 UTC
Created attachment 4286 [details]
LinkSDK_Verified logs
Comment 6 GouriKumari 2013-07-08 12:34:00 UTC
Verified linksdk tests with the latest Xamarin.iOS master-3.0 heads. The tests are fixed. Log files are attached in comment 5

Test Environment: 
Xamarin.iOS: 401c1a7607d55bc8535c4d7cb30ee93342797502 
mono 3.0 : 1c4db5e0dd5dfd2ffedddf9308065fe78016414a 
iPodTouch 6.0