Bug 13015 - [Xamarin.iOS] MT3001 error thrown when Linker option is set to "Link All/ Link SDK Assemblies" in iOS projects
Summary: [Xamarin.iOS] MT3001 error thrown when Linker option is set to "Link All/ Lin...
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Pre-release ()
Version: 6.3.x
Hardware: PC Mac OS
: --- normal
Target Milestone: 6.4 (async)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-07-02 12:46 UTC by GouriKumari
Modified: 2013-07-08 07:18 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Comment 1 Sebastien Pouliot 2013-07-02 13:26:53 UTC
LLVM was bumped (and the build green) on 6.3.7.150.

Can you try again with the most recent version ?

Also whenever LLVM fails can you try the same build options *without* LLVM ? that will make it clear if the issue is related to the linker or the AOT compiler options.
Comment 2 Sebastien Pouliot 2013-07-02 13:37:10 UTC
Note that for #1 you need at least 6.3.7.148 to get around the issue (147 is between the mono bump and the related monotouch changes).
Comment 3 GouriKumari 2013-07-02 14:52:42 UTC
Retested with 6.3.7.150.pkg
monotouch_test llvmthumbsgen build successfully without throwing MT3001 error.

Test Configuration and results:
Enabled llvm,thumb,sgen and checked with all linker options (Dont Link, LinkAll, Link SDK). Project built successfully
Disabled LLVM and checked with all linker options. Again Project built successfully

Retested comment #1 with 6.3.7.147.pkg
Disabled llvm and enabled LinkAll assemblies. MT3001 error was thrown. 
Build output: https://gist.github.com/GouriKumari/217100fcab091925bb11

As mentioned in comment 2, MT3001 error got  fixed in builds newer to 6.3.7.147.pkg.
Comment 4 Sebastien Pouliot 2013-07-02 14:59:26 UTC
that's all right? if not please re-open and state what's still failing
Comment 6 narayanp 2013-07-08 07:18:57 UTC
Today we have checked this issue with following builds:

X.S 4.0.9(build 15)
Mono 3.1.0
Xamarin.iOS 6.3.7.177

And we have checked build the application after changing the options which are mentioned in Comment#3 we are successfully able to build the application, no error appears.

Changing the status to Verified.