Bug 12976 - [VS] Not getting Trigger popup when user run the application after selecting 'Bundle assemblies into Native code'
Summary: [VS] Not getting Trigger popup when user run the application after selecting ...
Status: VERIFIED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: 4.7.x
Hardware: PC Windows
: High major
Target Milestone: 4.8 (async)
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2013-07-01 10:12 UTC by narayanp
Modified: 2013-07-12 07:04 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description narayanp 2013-07-01 10:12:30 UTC
Steps to reproduce:
[Condition: License should be activated as Business]
1. Open or create android application in VS.
2. Set configuration as 'Release'
3. Open project properties.
4. Select Mono Android Option and check 'Bundle assemblies into Native code'.
5. Run the application.

Actual Result: When user run the application after selecting 'Bundle assemblies into Native code', It does not prompts us to activate with Enterprises/Priority as we have seen with Xamarin Studio shown in http://screencast.com/t/Azo6blUu. Also it shows packaging error which is mentioned in gist: https://gist.github.com/atin360/933692ea16ba95a6dcc5

Expected Result: If license is business on disk and user run the application in release mode after selecting 'Bundle assemblies into Native code' then it should prompts to activate as enterprises as in XamarinStudio.

Environment details:
All Windows
VS 2012/2010
Xamarin.Android 4.7.11-2-1

Regression Status:
This functionality not exists on Stable Xamarin.Android 4.6.8
Comment 1 PJ 2013-07-01 16:25:46 UTC
I believe this is implemented on master but not yet for the 4.7.11-2 alpha build. I think we can promote to beta here with this build and then have the pricing pop-up appear in the RC.
Comment 2 PJ 2013-07-09 18:35:54 UTC
This was implemented for both XS and VS, and is available in the latest 4.7+ test builds to verify.
Comment 3 PJ 2013-07-09 18:36:21 UTC
For XS, the feature is in the 4.0.9 (build 15) Xamarin Studio (and higher).
Comment 4 narayanp 2013-07-12 06:40:44 UTC
Today we have checked this issue with following build:

All Windows
VS 2012/2010
Xamarin.Android 4.8.0-1

Now we are getting Trigger popup when selecting option 'Embed assemblies in native code' when license is Starter/Indie/Business and Trial on Disk.

We have reported an issue for Trail Bug 13201

Changing the status to Verified
Comment 5 narayanp 2013-07-12 07:04:12 UTC
Xamarin.Android version is 4.0.8-1 in Comment#4