Bug 12944 - Getting package creation failed error after selecting embed assemblies option for Android application
Summary: Getting package creation failed error after selecting embed assemblies option...
Status: VERIFIED INVALID
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: 4.7.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2013-06-28 15:58 UTC by Atin
Modified: 2013-07-01 01:58 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED INVALID

Description Atin 2013-06-28 15:58:02 UTC
Steps to reproduce this issue:
1. Open or create android application.
2. Go to project option->Android Build.
3. Check the option "Embed assemblies in native code"
4. Debug or Run the application.

Actual result: When user debug or Run the application after selecting "Embed
assemblies in native code" in project option, Getting error 'Deployment Failed.
Internal error'.  
Error: /Users/imac/Projects/test200/test200: Error XA5101: Missing Android NDK toolchains directory '/toolchains'. Please install the Android NDK. (XA5101) (test200)

Expected Result: Application should run successfully after selecting "Embed
assemblies in native code" in project option.

Build output: https://gist.github.com/atin360/2e170bda8935cb8d45ac

Environment details:
Mac ML 10.8.4
XS 4.0.9(build 12)- 7e55c1fd-a596-49b6-aa8c-d7373bde61d5
Mono 3.0.12
MFA 4.7.11.2

On monday we will add additional information regarding this issue.
Comment 1 PJ 2013-06-28 16:03:01 UTC
As the error states, the NDK is required to use this feature.

This should be installed by the unified installer, so you can run the installer to get it. 

You can also get it directly from here: http://developer.android.com/tools/sdk/ndk/index.html

Just be sure to set your Xamarin Studio SDK Location for the NDK to the downloaded/extracted location.

After that, please try again!
Comment 2 Nischal 2013-07-01 01:58:37 UTC
Today we have checked this thing after setting NDK in XamarinStudio-Preferences. We are successfully able to run the application in release mode after selecting "Embed assemblies in native code" in project option. 

Environment details:
All Mac
XS 4.0.9(build 12)
Mono 3.0.12
MFA 4.7.11-2-1

Changing the status to Verified