Bug 12932 - Editor is hiding a large portion of my code (in a specific file)
Summary: Editor is hiding a large portion of my code (in a specific file)
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 4.0.9
Hardware: Macintosh Mac OS
: Highest normal
Target Milestone: master
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2013-06-27 21:45 UTC by Adam
Modified: 2014-01-17 06:20 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
The source file that does not show completely in Xamarin editor (1.03 KB, application/octet-stream)
2013-06-27 21:45 UTC, Adam
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Adam 2013-06-27 21:45:33 UTC
Created attachment 4217 [details]
The source file that does not show completely in Xamarin editor

I dont know how this came about - because all I did, was copy the content of a source file to clipbaord (becuase I was going to delete the file) - paste it into TextPad, then delete the file in Xamarin, create a new C# file, and paste it back in... but only the first few lines of text appeared!!

So, I went back to TextEdit, and just saved the content over the top of the source file that Xamarin had open.
Xamarin asked me if I wanted to reload, I said yes, but still, only half the content was visible.
Here is the file (attached)
Comment 1 Mikayla Hutchinson [MSFT] 2013-06-27 22:12:28 UTC
What version of Xamarin Studio? Do you have a screenshot?
Comment 2 Mike Krüger 2013-06-28 02:19:28 UTC
fixed - thanks for the file, without it it wouldn't have been possible.
Comment 3 Mike Krüger 2013-06-28 06:50:18 UTC
I mark it as high - even if it's unlikely that this happens I consider it as a critical bug.

(IDEs shouldn't eat code - ok technically in that case the code isn't eaten - it's just put into the stove)
Comment 4 Mike Krüger 2013-06-28 06:50:37 UTC
Note: that requires mcs patches as well.
Comment 5 Adam 2013-06-28 19:42:16 UTC
Sorry - only just got back online now!

I did try making a video - but my Mac is refusing to comply ;) Good times.

Great to hear it is fixed. Thanks team!
Comment 6 narayanp 2014-01-17 06:20:10 UTC
I have checked this issue with following builds:

All Mac
X.S 4.2.3(build 127)
X.Android 4.12.0-8
X.iOS 7.0.6-167

Now I am getting full code when paste into new file. This is the screncast for the same: http://screencast.com/t/wnui3OOiaco