Bug 12888 - xamarin studio opens wrong file or shows wrong content
Summary: xamarin studio opens wrong file or shows wrong content
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Android Designer ()
Version: 4.0.8
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: master
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2013-06-25 20:12 UTC by Jens
Modified: 2014-01-21 02:15 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
screenshot showing the problem (506.29 KB, image/jpeg)
2013-06-26 04:29 UTC, Jens
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Jens 2013-06-25 20:12:53 UTC
strange bug where xamarin studio seems to load the wrong file...

how to reproduce:
go to http://docs.xamarin.com/guides/android/platform_features/fragments/fragments_walkthrough and download the sample source FragmentsWalkthrough4.zip

Unzip it and open the .SLN file in xamarin studio. 
Open the file "FragmentSample -> HoneycombFragments -> Resources -> Layout-Large -> activity_main.axml"

Now open the same file directly from the filesystem in a different editor.
If you compare both files, you can see, that the File in the other editor is larger and contains the details FrameLayout, while this part is missing in the file xamarin studio shows. 
As this part explains, why the app behaves differently on tablet and phone, it is really confusing and took me hours to understand ;)

I'll add a screenshot which shows the behaviour


version infos:

Xamarin Studio
Version 4.0.8 (build 2)
Installation UUID: ef46ec6d-cbfa-4264-bb42-00cdaa25736e
Runtime:
	Mono 2.10.12 (mono-2-10/c9b270d)
	GTK 2.24.16
	GTK# (2.12.0.0)
	Package version: 210120000

Xamarin.Android
Version: 4.6.8 (Business Edition)
Android SDK: /Users/jens-uwe/Downloads/Programme/android-sdk-macosx
	Supported Android versions:
		2.1 (API level 7)
		2.2 (API level 8)
		2.3 (API level 10)
		3.1 (API level 12)
		4.0 (API level 14)
		4.1 (API level 16)
		4.2 (API level 17)
Java SDK: /usr

Apple Developer Tools
Xcode 4.6.2 (2067.2)
Build 4H1003

Xamarin.Mac
Xamarin.Mac: Not Installed

Xamarin.iOS
Version: 6.2.7.1 (Business Edition)
Hash: 947e664
Branch: 
Build date: 2013-30-05 18:02:40-0400

Build Information
Release ID: 400080002
Git revision: 0a09117dec1aed78c735ac46f7a50ae7d12f7a7a
Build date: 2013-05-16 19:36:29+0000
Xamarin addins: 78d0437c3f92ae13042f81e5fd9487e2c28d5fbc

Operating System
Mac OS X 10.8.4
Darwin Jens-Uwes-MacBook-Pro.local 12.4.0 Darwin Kernel Version 12.4.0
    Wed May  1 17:57:12 PDT 2013
    root:xnu-2050.24.15~1/RELEASE_X86_64 x86_64
Comment 1 Mike Krüger 2013-06-26 03:11:24 UTC
A screenshot would be helpful - that's what I get:

http://screencast.com/t/hzq9WrO5

It looks like the file in any other editor.
Comment 2 Jens 2013-06-26 04:29:21 UTC
Created attachment 4201 [details]
screenshot showing the problem
Comment 3 Jens 2013-06-26 04:31:45 UTC
Ok, I just uploaded the screenshot.
if it shows the content as in your screenshot everything is OK, but here it wasn't.
Please note that I use the Xamarin Studio from "stable", which might be outdated by now?
Comment 4 Mike Krüger 2013-06-26 05:56:35 UTC
I can repro the bug - it's the android designer. It seems it recreates the xml.
Comment 5 Lluis Sanchez 2013-08-29 10:14:41 UTC
This issue is already fixed.
Comment 6 Nischal 2014-01-21 02:15:50 UTC
We have checked and now we are seeing same details for .axml file, if opened in XS editor or in other some editor like Text editor. 
Screencast: http://screencast.com/t/G9DGVo26eg

Environment info:
Xamarin Studio
Version 4.2.3 (build 146)
Git revision: 76e7c7f6ca0e59052f2bb29f8179313510977377

Xamarin.iOS
Version: 7.0.7.58
Hash: c2679f9

Mono 3.2.6 ((no/9b58377)

Xam.Android 4.13.0-36 (Mac Master)