Bug 12831 - Moving code around causes both an error and messed up UI
Summary: Moving code around causes both an error and messed up UI
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 4.1
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: 4.2.4 (from master)
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2013-06-22 06:52 UTC by Paul Johnson
Modified: 2014-02-13 11:34 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Video of UI issue in action (3.33 MB, application/x-shockwave-flash)
2013-06-22 06:52 UTC, Paul Johnson
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Paul Johnson 2013-06-22 06:52:47 UTC
Created attachment 4180 [details]
Video of UI issue in action

When moving code around within a file, the cursor jumps around erratically with the final placement not being where it needs to be. When it is put back, an error occurs (details in the attached video)

Using XS 4.1.4 on a Mac
Comment 1 Mike Krüger 2013-06-26 02:17:20 UTC
Should be fixed in master.
Comment 4 Mohit Kheterpal 2014-02-13 08:49:36 UTC
Today we have checked this issue with following builds :

XS 4.2.4 (build 17)

Now we are not getting any error and cursor does not jump erratically.

Screencast: http://screencast.com/t/rNQd2kmYxI4X

Hence, closing this issue.
Comment 5 Paul Johnson 2014-02-13 10:45:07 UTC
Try it on alpha before closing it
Comment 6 PJ 2014-02-13 11:25:44 UTC
Hi Paul,

The current Alpha is actually somewhat behind the 4.2.4 build in terms of the fixes it contains. The key differentiating feature in the Alpha right now is the iOS Designer.

There will definitely be an update to the Alpha channel that contains the same fix that made it into the 4.2.4 test builds.
Comment 7 Paul Johnson 2014-02-13 11:32:05 UTC
Odd - nothing is showing on the updates in Alpha at all. Infact, there hasn't been any sort of update in there for quite a while!
Comment 8 PJ 2014-02-13 11:34:13 UTC
It's not there yet, sorry.