Bug 12787 - "AnimatedClock" sample throws 'System.NullReferenceException' error.
Summary: "AnimatedClock" sample throws 'System.NullReferenceException' error.
Status: VERIFIED FIXED
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Samples ()
Version: 1.4.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Aaron Bockover [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2013-06-20 08:43 UTC by Prashant manu
Modified: 2013-06-20 11:47 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Prashant manu 2013-06-20 08:43:58 UTC
Steps to reproduce this issue:
1. Install Xamarin.Mac and XS.
2. Open XS.
3. Open 'AnimatedClock' application.
4. Run/Debug the application for linker (Include Mono Runtime | Link Framework SDKs /Link All) 

Actual result: AnimatedClock sample throws 'System.NullReferenceException' when run/debug with linker :
(Include Mono Runtime | Link Framework SDKs OR Link All). It is working fine with default debug/release configuration

Expected result: No exception should be thrown.

Supplement info:
Exception Detail:https://gist.github.com/atin360/ad37d45c955b70bec1f9
Screencast URL: http://screencast.com/t/xTBvRM8g

Environment details:
All mac
Xamarin.Mac 1.4.21
XS 4.0.8(build2)
Mono 2.10.12

App info:
mac-samples-master-39a2aa7d9e1bd65f3c4fc44b5807221e46306d8b
Comment 1 Prashant manu 2013-06-20 09:31:48 UTC
An update to above issue:

Regression status:
REGRESSION: This is working fine with Xamarin.Mac1.4.8
Comment 2 Aaron Bockover [MSFT] 2013-06-20 10:30:18 UTC
This is now fixed: https://github.com/xamarin/xamcore/commit/55d845fffc5abfd9e47ebe51bde0c2edfaf16e5d
Comment 3 Atin 2013-06-20 11:47:37 UTC
Today, We have checked this issue with:

XS 4.0.8
Xam.mac 1.4.22
Mono 2.10.12

Now application is run successfully for linker (Include Mono Runtime | Link Framework
SDKs /Link All)  without throwing any exception.

Hence marking this as Verified Fixed.