Bug 12758 - HeapShot does not take memory snapshot
Summary: HeapShot does not take memory snapshot
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 6.2.x
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
: 12177 ()
Depends on:
Blocks:
 
Reported: 2013-06-19 05:56 UTC by Lucian Torje
Modified: 2013-11-13 07:06 UTC (History)
12 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
screenshot (44.38 KB, image/png)
2013-06-19 05:56 UTC, Lucian Torje
Details
App Output from Case #47144 (214 bytes, text/plain)
2013-09-24 10:27 UTC, Allie Miller
Details
Device Console Output from Case #47144 (9.21 KB, text/plain)
2013-09-24 10:27 UTC, Allie Miller
Details
Xamarin Studio logs from Case $47144 (11.63 KB, application/zip)
2013-09-24 10:28 UTC, Allie Miller
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Lucian Torje 2013-06-19 05:56:33 UTC
Created attachment 4154 [details]
screenshot

On demand memory snapshot does not work at all and after a while it returns and error.
On major GC generates snapshots
Every 200ms does 1, maximum 2 heapshots, after that no further heapshots are made.

The test involves a xamarin ios library used from a xamarin ipad single view test app.

=== Xamarin Studio ===

Version 4.1.4 (build 117)
Installation UUID: 480641ea-25a7-4d52-8b33-04edae97af3a
Runtime:
	Mono 3.0.10 ((no/eff4cb5)
	GTK 2.24.18
	GTK# (2.12.0.0)
	Package version: 300100000

=== Apple Developer Tools ===

Xcode 4.6.2 (2067.2)
Build 4H1003

=== Xamarin.Mac ===

Xamarin.Mac: Not Installed

=== Xamarin.Android ===

Version: 4.7.8 (Business Edition)
Android SDK: /Users/lucian/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
Java SDK: /usr
java version "1.6.0_45"
Java(TM) SE Runtime Environment (build 1.6.0_45-b06-451-11M4406)
Java HotSpot(TM) 64-Bit Server VM (build 20.45-b01-451, mixed mode)

=== Xamarin.iOS ===

Version: 6.3.6.76 (Business Edition)
Hash: cdd868f
Branch: 
Build date: 2013-03-06 10:32:55-0400

=== Build Information ===

Release ID: 401040117
Git revision: e0f38912731e43ed9d3f1a410dd4fd907e7f1ba0
Build date: 2013-06-11 19:29:58+0000
Xamarin addins: 8fd84026361c1969794b85bee48efab97a5f33b3

=== Operating System ===

Mac OS X 10.8.4
Darwin Lucians-MacBook-Pro.local 12.4.0 Darwin Kernel Version 12.4.0
    Wed May  1 17:57:12 PDT 2013
    root:xnu-2050.24.15~1/RELEASE_X86_64 x86_64
Comment 1 Rolf Bjarne Kvinge [MSFT] 2013-06-21 03:46:34 UTC
Is this on device or in the simulator?

Can you add "-v -v -v -nofastsim" to the additional mtouch arguments, and then attach what's written to the Application Output in Xamarin Studio and Device Log (if running on device)?
Comment 2 Vitali 2013-08-14 04:38:40 UTC
I have a the same issue... But I cannot attach the log file because our application has a very-very big output:)
Comment 3 Tommy Baggett 2013-08-28 20:09:41 UTC
I'm also having the problem with the profile not connecting to my device.  Per Betai, I added the mtouch arguments.  Here's my XS console output.  I will attach the device console output separately.

XS Application Output:
Please ensure your device is connected...
Connected to: Tommy Baggett’s iPhone
Launching /private/var/mobile/Applications/1B3D43B7-C1EC-4E2C-A681-76D49D9F7A16/XNotes_iOS.app -debugtrack -monodevelop-port 10000 -connection-mode usb
Comment 7 Allie Miller 2013-09-24 10:27:18 UTC
Created attachment 4969 [details]
App Output from Case #47144
Comment 8 Allie Miller 2013-09-24 10:27:53 UTC
Created attachment 4970 [details]
Device Console Output from Case #47144
Comment 9 Allie Miller 2013-09-24 10:28:46 UTC
Created attachment 4972 [details]
Xamarin Studio logs from Case $47144
Comment 10 Rolf Bjarne Kvinge [MSFT] 2013-09-27 08:43:19 UTC
Fixed.

md-addins/master: 5fc47c546cf07fbe0dc7643947ba5277b3fd834c
Comment 11 Rolf Bjarne Kvinge [MSFT] 2013-09-30 03:11:03 UTC
*** Bug 12177 has been marked as a duplicate of this bug. ***
Comment 12 Allie Miller 2013-10-18 13:53:55 UTC
This issue seems to have re-appeared in Xamarin Studio v4.0.13 and Xamarin.iOS v7.0.2.7
Comment 13 Rolf Bjarne Kvinge [MSFT] 2013-10-21 04:31:11 UTC
The fix is not in v4.0.13.

Jeff, do you know which version of Xamarin Studio will have the fix from comment #10?
Comment 14 Jeffrey Stedfast 2013-10-21 09:30:55 UTC
It will be in 4.2.0
Comment 15 Saurabh 2013-11-13 07:06:46 UTC
I have checked this issue with latest builds:

XamarinStudio-4.2(Build 2)- a37a8e0cda771d222cabe1f9af29c4d586e7fc7d
monotouch-7.0.4.209

Device info: iPOD iOS 6.0.2

Now, HeapShot takes memory snapshot for device. On clicking to 'Take a Memory Snapshot', it takes a snapshot and a Checkbox appears in Heap Shot window.

http://screencast.com/t/hSo0Z23e5KDY

Hence, closing this issue.