Bug 12751 - ArgumentNullException putting breakpoint on System.Console.WriteLine
Summary: ArgumentNullException putting breakpoint on System.Console.WriteLine
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: Trunk
Hardware: PC Mac OS
: --- normal
Target Milestone: master
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2013-06-18 19:45 UTC by Mikayla Hutchinson [MSFT]
Modified: 2014-01-24 07:14 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Mikayla Hutchinson [MSFT] 2013-06-18 19:45:05 UTC
System.ArgumentNullException: Argument cannot be null.
Parameter name: value
  at System.String.Join (System.String separator, System.String[] value) [0x0001e] in /Users/michael/Mono/bockbuild/profiles/monodevelop-mac-dev/build-root/mono-/mcs/class/corlib/System/String.cs:2370 
  at Mono.Debugging.Soft.SoftDebuggerSession.OnInsertBreakEvent (Mono.Debugging.Client.BreakEvent ev) [0x00076] in /Users/michael/Mono/monodevelop/main/external/debugger-libs/Mono.Debugging.Soft/SoftDebuggerSession.cs:763 
  at Mono.Debugging.Client.DebuggerSession.AddBreakEvent (Mono.Debugging.Client.BreakEvent be) [0x00002] in /Users/michael/Mono/monodevelop/main/external/debugger-libs/Mono.Debugging/Mono.Debugging.Client/DebuggerSession.cs:548
Comment 1 Jeffrey Stedfast 2013-06-19 12:35:06 UTC
fixed in git master
Comment 2 Atin 2014-01-24 07:14:13 UTC
Today, we have checked this issue with:

XS 4.2.3(build 154)- 4dca4a28d7ecc2c4df8a4d58e74b8902d0283b53
Xamarin addins:cc120a6f639fa6649aa4d23a0f0e7c5701134047
MT 7.0.7.64
ML 10.8.5

Now this issue is not exist, we are successfully able to set breakpoint on System.Console.WriteLine in Console application without any Exception.

Screencast: http://www.screencast.com/t/Duk6NzDyY4QN

Hence marking this as Verified.