Bug 12747 - Identifier and Version not being saved
Summary: Identifier and Version not being saved
Status: VERIFIED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 0.x Insider Preview
Hardware: PC Windows
: Normal major
Target Milestone: 3.1
Assignee: Jose Miguel Torres
URL:
Depends on:
Blocks:
 
Reported: 2013-06-18 16:25 UTC by Doug G
Modified: 2014-06-09 10:06 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Doug G 2013-06-18 16:25:55 UTC
I've created a new Hello World app in v1.2.121 and I want to define an identifier and version number (right-clicking on the project in Solution Explorer, selecting Properties, and selecting iOS Application). These are not being saved and preventing me from debugging (see forum post: http://forums.xamarin.com/discussion/1547/unable-to-debug-in-simulator-on-mac-mini-from-windows-8) and causes the iOS Simulator to crash saying the simulated application has quit. Relaunching and switching SDK don't resolve the error.
Comment 1 Jose Miguel Torres 2013-06-19 04:39:46 UTC
Hi Doug G,

There will be a new PList editor in the next release that will fix most of the issues regarding to the iOS Application information. 

However, I am about to leave this bug as CONFIRMED (not closed) since there are some features we have to improve, as the mac build host error reporting in the event the iOS simulator returned an typified error.

Thanks,
Comment 2 Marek Habersack 2013-06-19 05:18:59 UTC
Doug,

As a workaround until the new version is released you can edit the Info.plist file directly and add the required keys manually. Alternatively, the same can be done using Xamarin Studio on Mac.
Comment 3 Jose Miguel Torres 2014-06-03 04:03:05 UTC
Fixed on XVS 3.0.54
Comment 4 Mohit Kheterpal 2014-06-09 10:06:27 UTC
I have checked this issue and now I am able to save Identified and version and able to deploy application on simulator successfully as shown in screencast :http://screencast.com/t/FLZ99cbAqd26

Hence closing this issue.

Please let me know, if I have to check something else to verify this issue.