Bug 12718 - [iOS5.1]Getting "MonoTouch.Foundation.MonoTouchException" for Template iPhoneStoryboard-MasterDetailed application
Summary: [iOS5.1]Getting "MonoTouch.Foundation.MonoTouchException" for Template iPhone...
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: 4.0.7
Hardware: PC Mac OS
: High major
Target Milestone: 4.0.10 (for async)
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2013-06-17 06:39 UTC by narayanp
Modified: 2013-07-16 08:36 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description narayanp 2013-06-17 06:39:56 UTC
Steps to reproduce this issue:
1. Create iPhoneStoryBoard-MasterDetailed application.
2. Debug or run the application.
3. Click on '+'icon on device/simulator

Actual result:
When user click on '+' icon of MasterDetailed application of iPhoneStoryBoard, application get crashed and throwing exception on Device or simulator of version 5.1

Expected Result:
Application should not crashed after clicking on '+' icon.

Supplement info:
Application Output: https://gist.github.com/atin360/f1c220fc436f413832e3

Device info:
iPhone4 Version 5.1
iOS Simulator version 5.1

Environment details:
All Mac
X.S 4.0.7
Xamarin.iOS 6.3.6.76
Mono 3.0.11

Regression Status:
This is happening with Xamarin.iOS 6.3.7.1
Comment 1 Sebastien Pouliot 2013-06-17 08:48:07 UTC
2013-06-17 15:49:52.444 jhsgd[1217:1d603] -[UITableView dequeueReusableCellWithIdentifier:forIndexPath:]: unrecognized selector sent to instance 0xb14e400

^ This is a iOS 6+ API [1] so it won't work on iOS 5.1.

ref: http://developer.apple.com/library/ios/#documentation/uikit/reference/UITableView_Class/Reference/Reference.html

The template (shipped with the addin) needs to be modified to be compatible with the older API that works with 5.x.
Comment 2 Jeffrey Stedfast 2013-06-20 15:46:04 UTC
I don't think we care. Xcode 4.6's Master/Detail template also uses 6.0 APIs and it's probably pretty reasonable that most new apps will target >= 6.0 anyway.

I've modified the Info.plist templates to default the MinimumOSVersion to 6.0 instead of 3.2, so that should be enough.
Comment 3 narayanp 2013-07-04 07:45:19 UTC
Today I have checked this issue with following builds:

All Mac
X.S 4.0.9(build 12)
Mono 3.0.12
Xamarin.iOS 6.3.7-164

We have created Template for iPhoneStoryboard->MasterDetailed and we are still seeing minimum target version as 5.0 and we are getting crashed after clicking on '+' icon on iOS Simulator having version 5.1.
http://screencast.com/t/6aGH1yVh

Hence, Reopening this issue
Comment 4 Jeffrey Stedfast 2013-07-08 17:39:23 UTC
this was only fixed in master, not 4.0.9
Comment 5 PJ 2013-07-12 19:31:11 UTC
IMO, this fix should be back-ported to 4.0.10. It's essentially just a crashing template when you have the 5.1 simulators installed.
Comment 6 narayanp 2013-07-15 08:23:13 UTC
Today I have checked this issue with following builds:

All Mac
X.S 4.0.10(build 3)
Mono 3.1.1-2
Xamarin.iOS 6.3.8-5

We have created Template for iPhoneStoryboard->MasterDetailed and we observed that minimum target version as 5.0 application deployed to iOS simulator but does not launch and get terminated.
http://screencast.com/t/SPRj6DV6

Hence reopening this issue
Comment 7 Jeffrey Stedfast 2013-07-15 12:08:12 UTC
backported to 4.0.10
Comment 8 narayanp 2013-07-16 08:36:03 UTC
Today I have checked this issue with following builds

All Mac
X.S 4.0.10(build 5)
Mono 3.1.2
Xamarin.iOS 6.3.8-10

Now I am seeing minimum Deployment Target as 6.0 for iPhoneStoryboard-MasterDetailed application. This is the screencast for the same: http://screencast.com/t/npeNGt3F03e

Changing the status to Verified