Bug 12701 - Rebase to Branch doesn't pull any changes in from remote
Summary: Rebase to Branch doesn't pull any changes in from remote
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Version Control ()
Version: 4.1
Hardware: PC Mac OS
: Normal normal
Target Milestone: master
Assignee: Marius Ungureanu
URL:
Depends on:
Blocks:
 
Reported: 2013-06-14 16:31 UTC by Nina
Modified: 2013-07-12 12:19 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
rebase (371.20 KB, image/png)
2013-06-14 16:33 UTC, Nina
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Nina 2013-06-14 16:31:40 UTC
If you select Version Control -> Rebase to branch, and then click on a remote branch under origin, and rebase, absolutely _nothing_ happens.
Comment 1 Nina 2013-06-14 16:33:07 UTC
Created attachment 4120 [details]
rebase
Comment 2 Marius Ungureanu 2013-07-02 09:28:25 UTC
I am unable to reproduce.
Comment 3 Nina 2013-07-02 12:25:31 UTC
Set up a git repo, make changes locally and in remote, and then try to rebase to the remote branch.
Comment 4 Marius Ungureanu 2013-07-12 12:03:22 UTC
Ah, there's no fetching done from remote. Will fix.
Comment 5 Marius Ungureanu 2013-07-12 12:19:24 UTC
Fixed and will be included in upcoming releases.