Bug 12693 - mdtool crashes when building .sln file
Summary: mdtool crashes when building .sln file
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Shell ()
Version: 4.0.8
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-06-14 12:21 UTC by Razvan Pascalau
Modified: 2014-01-21 01:56 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Razvan Pascalau 2013-06-14 12:21:41 UTC
i am building an ios app from a .sln and after the .ipa file is created this happens

warning: Could not resolve host IPs for debugger settings
* Assertion at threads.c:1360, condition `internal' not met


Unhandled Exception:
System.ObjectDisposedException: The object was used after being disposed.

Server stack trace:
  at System.Net.Sockets.Socket.Poll (Int32 time_us, SelectMode mode) [0x0009c] in /private/tmp/source/bockbuild-crypto-mono/profiles/mono-mac-xamarin/build-root/mono-3.0.10/mcs/class/System/System.Net.Sockets/Socket.cs:1493
  at System.Runtime.Remoting.Channels.Tcp.ReusableTcpClient.get_IsAlive () [0x00008] in /private/tmp/source/bockbuild-crypto-mono/profiles/mono-mac-xamarin/build-root/mono-3.0.10/mcs/class/System.Runtime.Remoting/System.Runtime.Remoting.Channels.Tcp/TcpConnectionPool.cs:148
  at System.Runtime.Remoting.Channels.Tcp.TcpConnection.get_IsAlive () [0x00000] in /private/tmp/source/bockbuild-crypto-mono/profiles/mono-mac-xamarin/build-root/mono-3.0.10/mcs/class/System.Runtime.Remoting/System.Runtime.Remoting.Channels.Tcp/TcpConnectionPool.cs:183
  at System.Runtime.Remoting.Channels.Tcp.HostConnectionPool.GetConnection () [0x0005a] in /private/tmp/source/bockbuild-crypto-mono/profiles/mono-mac-xamarin/build-root/mono-3.0.10/mcs/class/System.Runtime.Remoting/System.Runtime.Remoting.Channels.Tcp/TcpConnectionPool.cs:234
  at System.Runtime.Remoting.Channels.Tcp.TcpConnectionPool.GetConnection (System.String host, Int32 port) [0x0005c] in /private/tmp/source/bockbuild-crypto-mono/profiles/mono-mac-xamarin/build-root/mono-3.0.10/mcs/class/System.Runtime.Remoting/System.Runtime.Remoting.Channels.Tcp/TcpConnectionPool.cs:105
  at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.ProcessMessage (IMessage msg, ITransportHeaders requestHeaders, System.IO.Stream requestStream, ITransportHeaders& responseHeaders, System.IO.Stream& responseStream) [0x00025] in /private/tmp/source/bockbuild-crypto-mono/profiles/mono-mac-xamarin/build-root/mono-3.0.10/mcs/class/System.Runtime.Remoting/System.Runtime.Remoting.Channels.Tcp/TcpClientTransportSink.cs:183
  at System.Runtime.Remoting.Channels.BinaryClientFormatterSink.SyncProcessMessage (IMessage msg) [0x0006c] in /private/tmp/source/bockbuild-crypto-mono/profiles/mono-mac-xamarin/build-root/mono-3.0.10/mcs/class/System.Runtime.Remoting/System.Runtime.Remoting.Channels/BinaryClientFormatterSink.cs:157

Exception rethrown at [0]:

  at System.Net.Sockets.Socket.Poll (Int32 time_us, SelectMode mode) [0x0009c] in /private/tmp/source/bockbuild-crypto-mono/profiles/mono-mac-xamarin/build-root/mono-3.0.10/mcs/class/System/System.Net.Sockets/Socket.cs:1493
  at System.Runtime.Remoting.Channels.Tcp.ReusableTcpClient.get_IsAlive () [0x00008] in /private/tmp/source/bockbuild-crypto-mono/profiles/mono-mac-xamarin/build-root/mono-3.0.10/mcs/class/System.Runtime.Remoting/System.Runtime.Remoting.Channels.Tcp/TcpConnectionPool.cs:148
  at System.Runtime.Remoting.Channels.Tcp.TcpConnection.get_IsAlive () [0x00000] in /private/tmp/source/bockbuild-crypto-mono/profiles/mono-mac-xamarin/build-root/mono-3.0.10/mcs/class/System.Runtime.Remoting/System.Runtime.Remoting.Channels.Tcp/TcpConnectionPool.cs:183
  at System.Runtime.Remoting.Channels.Tcp.HostConnectionPool.GetConnection () [0x0005a] in /private/tmp/source/bockbuild-crypto-mono/profiles/mono-mac-xamarin/build-root/mono-3.0.10/mcs/class/System.Runtime.Remoting/System.Runtime.Remoting.Channels.Tcp/TcpConnectionPool.cs:234
  at System.Runtime.Remoting.Channels.Tcp.TcpConnectionPool.GetConnection (System.String host, Int32 port) [0x0005c] in /private/tmp/source/bockbuild-crypto-mono/profiles/mono-mac-xamarin/build-root/mono-3.0.10/mcs/class/System.Runtime.Remoting/System.Runtime.Remoting.Channels.Tcp/TcpConnectionPool.cs:105
  at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.ProcessMessage (IMessage msg, ITransportHeaders requestHeaders, System.IO.Stream requestStream, ITransportHeaders& responseHeaders, System.IO.Stream& responseStream) [0x00025] in /private/tmp/source/bockbuild-crypto-mono/profiles/mono-mac-xamarin/build-root/mono-3.0.10/mcs/class/System.Runtime.Remoting/System.Runtime.Remoting.Channels.Tcp/TcpClientTransportSink.cs:183
  at System.Runtime.Remoting.Channels.BinaryClientFormatterSink.SyncProcessMessage (IMessage msg) [0x0006c] in /private/tmp/source/bockbuild-crypto-mono/profiles/mono-mac-xamarin/build-root/mono-3.0.10/mcs/class/System.Runtime.Remoting/System.Runtime.Remoting.Channels/BinaryClientFormatterSink.cs:157
Comment 1 Razvan Pascalau 2013-06-14 12:25:35 UTC
i forgot to mention i use mdtool : /Applications/Xamarin\ Studio.app/Contents/MacOS/mdtool -v build "--configuration:Debug|iPhone" "project.sln"
Comment 2 Alan McGovern 2013-07-24 18:10:40 UTC
The next stable release of Xamarin Studio will have the fix for this. The fix is already in the newer alpha/beta releases we have been making so if this is a blocking issue you could update to any build from the 4.1.x series.
Comment 3 Nischal 2014-01-21 01:56:56 UTC
We have checked this issue with iPhone4S and are able to built iOS app from a .sln using mdtool. Screencast: http://screencast.com/t/S4Mzn2hvw

Supplement Info:
Build Output: https://gist.github.com/saurabh360/1a36079b1e68e54ad8fc

Environment info:
Xamarin Studio
Version 4.2.3 (build 146)
Git revision: 76e7c7f6ca0e59052f2bb29f8179313510977377

Xamarin.iOS
Version: 7.0.7.58
Hash: c2679f9

Mono 3.2.6 ((no/9b58377)

Xam.Android 4.13.0-36