Bug 12658 - "ExportAttributesTest" android sample gives build error
Summary: "ExportAttributesTest" android sample gives build error
Status: VERIFIED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: Samples ()
Version: 4.7.x
Hardware: All All
: --- normal
Target Milestone: ---
Assignee: Jonathan Pryor
URL:
Depends on:
Blocks:
 
Reported: 2013-06-12 12:04 UTC by Atin
Modified: 2013-06-18 12:26 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Atin 2013-06-12 12:04:45 UTC
Steps to reproduce:
1. Open "ExportAttributesTest" sample in X.S.
2. Debug or run the application.

Actual result:
Application giving 1 build error "Android.OS.Bundle does not contain a definition for `ClassLoader' and no extension method `ClassLoader' of type `Android.OS.Bundle' could be found". Are you missing an assembly reference?

Build output: https://gist.github.com/atin360/46f9300a92da4e88bbd4

Expected result:
Application should debug or run successfully.


Environment details:
All mac
Windows 7 and 8
XS 4.0.9(build 3)- 227b031b4ab7c3c0a956f1943b0a41a5d47cb62e
Mono 3.0.11
MFA 4.7.9-1
VS 2010/2012

App info: monodroid-samples-master d5c8297e5793e4fec09462008f25abe1f3d6a045


Regression status: REGRESSION, its working fine with stable MFA 4.6.8, XS 4.0.8 and Mono 2.10.12
Comment 1 Peter Collins 2013-06-13 18:54:52 UTC
I am still seeing this build error on the current stable XA (4.6.8), I do not believe this is a 4.7.9 specific regression.
Comment 2 Peter Collins 2013-06-17 18:00:41 UTC
JonP: Could you take a look at this when you have the chance, looks like you may have made some related changes to this sample recently?
Comment 3 Atin 2013-06-18 07:57:38 UTC
Today, I have checked this issue with stable builds:

XS 4.0.8
Mono 2.10.12 
MFA  4.6.8 
App info: monodroid-samples-master 7f15b5f09488631216f10b9255cfa3618d67d928

This issue is still exist with stable environment . Hence it is NOT A REGRESSION
Comment 4 Jonathan Pryor 2013-06-18 11:44:14 UTC
Should be fixed in monodroid-samples/a7a4e1a7.