Bug 12528 - DebugTypeProxyAttribute does not work in SoftDebugger for expanded generic types
Summary: DebugTypeProxyAttribute does not work in SoftDebugger for expanded generic types
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: 4.0.8
Hardware: PC Mac OS
: --- normal
Target Milestone: master
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2013-06-03 18:52 UTC by Ben Cooley
Modified: 2013-08-05 14:30 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Ben Cooley 2013-06-03 18:52:09 UTC
ObjectValueAdaptor checks for the arg count for the proxy type in DebugTypeProxyAttribute and ensures arg counts of the proxy and target type match, but should ignore type arguments for an expanded generic type.

Line 1062 in ObjectValueAdaptor.cs -         

public object GetProxyObject (EvaluationContext ctx, object obj)

…..

            int i = data.ProxyType.IndexOf ('`');
            if (i != -1) {


This fails when the proxy is actually expanded, because there will be a ` mark, followed by the expanded types [[type,type,type]] in the proxy type string.

It should check to see if there is an expansion type list following the type arg count.

This is a problem for us as we use Expando for our dynamic objects in PlayScript, and Expando's debug proxy can not use the CollectionDebugProxy<string, object> because of this.
Comment 1 Jeffrey Stedfast 2013-06-04 11:54:47 UTC
Could you give this build a try? https://files.xamarin.com/~jeff/XamarinStudio-d3111042052c0ca64d44a95f2615a7f00db5cd20.dmg
Comment 2 Jeffrey Stedfast 2013-08-05 14:30:24 UTC
pretty sure this has been fixed