Bug 12491 - [MTVS]Getting build error for 'MT9002' iOS sample.
Summary: [MTVS]Getting build error for 'MT9002' iOS sample.
Status: VERIFIED INVALID
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: iOS ()
Version: 0.x Insider Preview
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Marek Habersack
URL:
Depends on:
Blocks:
 
Reported: 2013-05-31 12:03 UTC by Saurabh
Modified: 2013-06-03 12:33 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
MT9002 (3.28 KB, application/zip)
2013-05-31 12:03 UTC, Saurabh
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED INVALID

Description Saurabh 2013-05-31 12:03:47 UTC
Created attachment 4049 [details]
MT9002

[Condition] Trail/higher license is activated

Open attached iOS sample 'MT9002' in VS and build the sample. 
Observe that it gives build error.
Build Error: "Error1 The type or namespace name 'Bindings' could not be found (are you missing a using directive or an assembly reference?)C:\Users\monup\Desktop\New folder\MT9002\MT9002\AppDelegate.cs"

When we try to add missing assembly in References folder then we are not getting Binding assembly in Add References window. 
However, on mac in XS we are able to add 'bindings-test.dll' file and after that build error disappears on XS.
But in VS we are not 'bindings-test.dll' file in Add References window.

Environment info:
VS 2010/2012
MTVS 1.2.103
MT 6.2.6.6

Regression Status: Not Regression. This issue also exist with MTVS 1.1.200(Stable).
Comment 1 Marek Habersack 2013-05-31 15:59:33 UTC
The .csproj file references ..\..\bindings\bindings-test.dll which does not exist. Not sure what's the original sample, but if it generates bindings from a native library then this is not supported in VS.
Comment 2 Saurabh 2013-06-03 06:59:24 UTC
Hi PJ,

Today we have checked this issue with above attached ios sample 'MT9002'  with bug. As per comment 1  The .csproj file references ..\..\bindings\bindings-test.dll does not exist. 

We have added missing bindingtest.dll file from  QualityAssurance-master/Automation/PricingTests/BuildErrorProjects/iOS/bindings/bindings-test.dll.

Now sample is build successfully with Trial, Business and priority License on VS. 

As per our understanding, now this issue can be closed as it is working fine, after adding the missing .dll file.

PJ, please confirm and closed this issue, if we are correct in our understanding or let us know your opinion for the same.
Comment 3 PJ 2013-06-03 12:33:58 UTC
Yes indeed, invalid until we support bindings in VS.