Bug 12453 - 4.6.7 IDE rebuilds project and recopies application on every Start command
Summary: 4.6.7 IDE rebuilds project and recopies application on every Start command
Status: RESOLVED FIXED
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Android ()
Version: unspecified
Hardware: PC Windows
: --- normal
Target Milestone: ---
Assignee: Dominique Louis
URL:
Depends on:
Blocks:
 
Reported: 2013-05-29 07:25 UTC by Robert Castles
Modified: 2016-08-03 15:25 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Robert Castles 2013-05-29 07:25:39 UTC
4.6.7, Windows 7 64 bit, Visual Studio 2012

1. Build project
2. Start project 

Result: application is immediately rebuilt despite having just been built.
Also, the application is repackaged and recopied to the device on subsequent Play commands, perhaps due to having been rebuilt 

Expected result is IDE would recognize project is built and ideally not require a redeploy to start the installed application.
Comment 1 Jonathan Pryor 2013-05-29 10:54:14 UTC
Please provide the diagnostic build output from (2).

Even if the IDE is rebuilding the project, it shouldn't _rebuild_ the project as nothing _should_ be out of data due to (1). The fact that it rebuilds everything implies that something is out of date, and the diagnostic build output will help.

This could plausibly be Bug #12432.
Comment 2 Robert Castles 2013-05-29 12:02:18 UTC
I cannot reproduce the issue.  I am closing for now.  I will continue to look for any patterns which might trigger this behavior and will include logs if so.