Bug 12415 - NRE while "Extracting embedded content"
Summary: NRE while "Extracting embedded content"
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 4.1
Hardware: PC Mac OS
: --- normal
Target Milestone: master
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2013-05-27 20:54 UTC by Sebastien Pouliot
Modified: 2013-06-28 16:11 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
attached BundledResources.dll (87.00 KB, application/octet-stream)
2013-05-27 20:54 UTC, Sebastien Pouliot
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Sebastien Pouliot 2013-05-27 20:54:01 UTC
Created attachment 4027 [details]
attached BundledResources.dll

Just updated to 4.1.2, tried to build unit tests for devices and got:

...
Build complete -- 0 errors, 0 warnings

Extracting embedded content

---------------------- Done ----------------------

Error extracting content from assembly '/Developer/MonoTouch/Source/monotouch/tests/BundledResources/bin/Debug/BundledResources.dll'. Object reference not set to an instance of an object
Build: 1 error, 0 warnings


Log shows:


ERROR [2013-05-27 20:41:17Z]: System.NullReferenceException: Object reference not set to an instance of an object
  at MonoDevelop.IPhone.IPhoneBuildExtension.ExtractFromContentAssembly (IProgressMonitor monitor, FilePath appDir, FilePath asmInBundle, System.Collections.Generic.HashSet`1 contentFileHash) [0x000a8] in /Users/builder/data/lanes/monodevelop_private-lion-splash2/f5460504/source/md-addins/MonoDevelop.IPhone/MonoDevelop.IPhone/Project/IPhoneBuildExtension.cs:631 
  at MonoDevelop.IPhone.IPhoneBuildExtension.UnpackContent (IProgressMonitor monitor, MonoDevelop.IPhone.IPhoneProjectConfiguration cfg, System.Collections.Generic.List`1 assemblies, System.Collections.Generic.HashSet`1 contentFileHash) [0x00270] in /Users/builder/data/lanes/monodevelop_private-lion-splash2/f5460504/source/md-addins/MonoDevelop.IPhone/MonoDevelop.IPhone/Project/IPhoneBuildExtension.cs:596 


The BundledResources.dll assembly is attached (looks fine and has mono touch_ resources)



More details:


=== Xamarin Studio ===

Version 4.1.2 (build 192)
Installation UUID: fefc3fc6-50d5-49e1-abcc-51c9cb82ba86
Runtime:
	Mono 3.0.10 ((no/0d3f3eb)
	GTK 2.24.18
	GTK# (2.12.0.0)
	Package version: 300100000

=== Apple Developer Tools ===

Xcode 4.6.2 (2067.2)
Build 4H1003

=== Xamarin.iOS ===

Version: 6.3.6.11 (Business Edition)

=== Xamarin.Android ===

Version: 4.6.0 (Business Edition)
Android SDK: /opt/android/sdk
	Supported Android versions:
		2.1 (API level 7)
		2.2 (API level 8)
		2.3 (API level 10)
		3.1 (API level 12)
		4.0 (API level 14)
Java SDK: /usr
java version "1.6.0_45"
Java(TM) SE Runtime Environment (build 1.6.0_45-b06-451-11M4406)
Java HotSpot(TM) 64-Bit Server VM (build 20.45-b01-451, mixed mode)

=== Xamarin.Mac ===

Xamarin.Mac: 1.3.13

=== Build Information ===

Release ID: 401020192
Git revision: f546050458ae02687a7fbf2178d8cf8455f2da8c
Build date: 2013-05-20 23:20:14+0000
Xamarin addins: ef49d8314090b0a3f561d6eb0473c3a5cc887627

=== Operating System ===

Mac OS X 10.7.5
Darwin castor.local 11.4.2 Darwin Kernel Version 11.4.2
    Thu Aug 23 16:25:48 PDT 2012
    root:xnu-1699.32.7~1/RELEASE_X86_64 x86_64
Comment 1 Jeffrey Stedfast 2013-05-28 15:32:38 UTC
should be fixed in git master (md-addins)
Comment 2 GouriKumari 2013-06-13 16:22:33 UTC
The above mentioned bug is occuring in QA bots running monotouchtests . I was able to reproduce it locally as well. 

Error log:  https://gist.github.com/GouriKumari/f9259a4292f11cda6290

Wrench Logs: https://wrench.internalx.com/Wrench/WebServices/Download.aspx?workfile_id=979262


Test Env:

XS 4.0.9 (8b3c179b3fd917007b9f50cb2283444d41cd9d08 )
Xamarin.iOS master 3.0 cfde9b54b3056d1c4af3d330ad52b36a76556f47
Comment 3 Jeffrey Stedfast 2013-06-13 16:58:25 UTC
This seems to be a different NRE than the one that Sebastien got.

This one is from the MD1 build engine and I have no clue how the projectItems could be null.
Comment 4 GouriKumari 2013-06-28 16:11:15 UTC
According to comment3 NRE reported in Comment2 is a new one. Created a new bug report 12945 for the same.

Hence marking this bug back to resolved fixed.