Bug 12408 - Sample 'GLFullScreen' and 'GLSLShader' are giving 3 build errors.
Summary: Sample 'GLFullScreen' and 'GLSLShader' are giving 3 build errors.
Status: VERIFIED FIXED
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Samples ()
Version: 1.2.x
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-05-27 09:46 UTC by Saurabh
Modified: 2013-05-29 15:52 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Comment 1 Saurabh 2013-05-27 09:58:18 UTC
An update to above issue:
We are getting same issue with 'GLSLShader' sample.

App info: mac-samples-master (1)1c5bc400039a88b3f9850e7dbcce5181e1ccdaca

Environment info: 
All Mac
Xam.Mac 1.3.55
XS 4.0.8(Build 2)
Mono 2.10.12
Comment 2 Aaron Bockover [MSFT] 2013-05-28 21:12:46 UTC
This is fixed in the latest Xamarin.Mac build.
Comment 3 GouriKumari 2013-05-29 15:52:17 UTC
With latest build of Xamarin.Mac  GLFullScreen and GLSLShader sample apps build successfully

GLFullScreen: https://gist.github.com/GouriKumari/1bfa6803e52b6b867e8e

GLSLShader : https://gist.github.com/GouriKumari/90830b323a7e1d8bd303

Marking the bug as verified fixed.


Test Env:

Xamarin Studio
Version 4.0.8 (build 2)
Installation UUID: fafd3486-1aec-4f9c-ab77-08bf4a000708
Runtime:
	Mono 2.10.12 (mono-2-10/c9b270d)
	GTK 2.24.16
	GTK# (2.12.0.0)
	Package version: 210120000


Xamarin.Mac
Xamarin.Mac: 1.4.8