Bug 12407 - Mac Sample "OpenGL-NeHe" giving build errors
Summary: Mac Sample "OpenGL-NeHe" giving build errors
Status: VERIFIED FIXED
Alias: None
Product: Xamarin.Mac
Classification: Desktop
Component: Samples ()
Version: 1.2.x
Hardware: PC Mac OS
: Normal normal
Target Milestone: 1.4.x
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-05-27 09:44 UTC by Nischal
Modified: 2013-05-29 16:05 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Nischal 2013-05-27 09:44:56 UTC
Steps to reproduce:
1. Open sample 'OpenGL-NeHe' any lesson from lesson 1 to lesson 17.
2. Build the sample.

Actual Result: Application giving 3 build errors.

Expected Result: Application should build successfully.

Supplement info:
Build output: https://gist.github.com/atin360/f9ea422ef16304c6319f

Environment details:
X.S 4.0.8(build 2)
Mono 2.10.12
Xamarin.Mac 1.3.55

Regression Status:
Regression: This is not happening with Xamarin.Mac 1.2.43
Comment 1 Aaron Bockover [MSFT] 2013-05-28 21:12:59 UTC
This is fixed in the latest Xamarin.Mac build.
Comment 2 GouriKumari 2013-05-29 16:05:15 UTC
Fixed with the latest build

Build Output : https://gist.github.com/GouriKumari/6d83565a666e9cf11b58

Test Env:

Xamarin Studio
Version 4.0.8 (build 2)
Installation UUID: fafd3486-1aec-4f9c-ab77-08bf4a000708
Runtime:
    Mono 2.10.12 (mono-2-10/c9b270d)
    GTK 2.24.16
    GTK# (2.12.0.0)
    Package version: 210120000


Xamarin.Mac
Xamarin.Mac: 1.4.8