Bug 12405 - Not able to add .icns image again in Mac OSX Application
Summary: Not able to add .icns image again in Mac OSX Application
Status: VERIFIED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Mac Add-in ()
Version: 4.0.8
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Aaron Bockover [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2013-05-27 07:48 UTC by narayanp
Modified: 2013-06-21 07:12 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description narayanp 2013-05-27 07:48:27 UTC
Steps to reproduce this issue:
1. Open or create Xamarin.Mac application.
2. Open Project option->Mac OS X Application
3. Under Summary tab Click on App Icon box.
4. Add .icns image and click OK.
5. Again go to option->Mac OS X Application
6. Now unset this .icns image and by right clicking on this App icon.
7. Try to set the same image.

Actual Result: When user try to set the same image again in App Image box, it is throwing exception "System.IO.IOException"

Expected Result: User should able to add same image every time after unset the image.

Supplement info;
https://gist.github.com/atin360/548ff37a77f46a28cc93

Environment details:
X.S 4.0.8(build 2)
Xamarin.Mac 1.3.55
Mono 2.10.12

Regression Status:
NOT A REGRESSION: We are seeing this issue with Xamarin.Mac 1.2.0
Comment 1 Jeffrey Stedfast 2013-06-06 14:29:30 UTC
fixed in git master (didn't make it in time for 4.0.9)
Comment 2 Atin 2013-06-21 07:12:29 UTC
Today, We have checked this issue with following builds:

XS 4.0.9(build 9)
Xam.mac 1.4.22
Mono 2.10.12

Now, We are able to add same .icns image every time after unset the image on App icon box under summary tab.

Hence marking this as Verified Fixed.