Bug 12362 - Millions of MuxTCPInputSCE errors output to the /var/log/system.log file
Summary: Millions of MuxTCPInputSCE errors output to the /var/log/system.log file
Status: RESOLVED DUPLICATE of bug 12734
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: 4.0.8
Hardware: Macintosh Mac OS
: High normal
Target Milestone: ---
Assignee: Rolf Bjarne Kvinge [MSFT]
URL:
Depends on:
Blocks:
 
Reported: 2013-05-23 11:16 UTC by Alek Slater
Modified: 2013-07-17 19:22 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 12734

Description Alek Slater 2013-05-23 11:16:53 UTC
After just 1 debug session on the iPad device using Xamarin Studio, i get a continuos stream of these errors in my system log.
It doesn't stop until I kill Xamarin Studio. I wouldn't normally complain about something like this, but it has a noticeable effect on performance.


May 23 16:12:13 skelimac.local com.apple.usbmuxd[72]: MuxTCPInputSCE received RST for 0x108-ba128398ed661eee09aa00bf12f69a199bc13141@0xfa120000:10000->0x101807410-XamarinStudio/com.xamarin.monodevelop:5189: handleConnectResult: failure - 61
May 23 16:12:13 skelimac.local com.apple.usbmuxd[72]: MuxTCPInputSCE received RST for 0x108-ba128398ed661eee09aa00bf12f69a199bc13141@0xfa120000:10000->0x101806b20-XamarinStudio/com.xamarin.monodevelop:5445: handleConnectResult: failure - 61
May 23 16:12:13 skelimac.local com.apple.usbmuxd[72]: MuxTCPInputSCE received RST for 0x108-ba128398ed661eee09aa00bf12f69a199bc13141@0xfa120000:10000->0x101d07fe0-XamarinStudio/com.xamarin.monodevelop:5701: handleConnectResult: failure - 61
May 23 16:12:13 skelimac.local com.apple.usbmuxd[72]: MuxTCPInputSCE received RST for 0x108-ba128398ed661eee09aa00bf12f69a199bc13141@0xfa120000:10000->0x101d03c60-XamarinStudio/com.xamarin.monodevelop:5957: handleConnectResult: failure - 61
May 23 16:12:13 skelimac.local com.apple.usbmuxd[72]: MuxTCPInputSCE received RST for 0x108-ba128398ed661eee09aa00bf12f69a199bc13141@0xfa120000:10000->0x101806b20-XamarinStudio/com.xamarin.monodevelop:6213: handleConnectResult: failure - 61
May 23 16:12:13 skelimac.local com.apple.usbmuxd[72]: MuxTCPInputSCE received RST for 0x108-ba128398ed661eee09aa00bf12f69a199bc13141@0xfa120000:10000->0x101807410-XamarinStudio/com.xamarin.monodevelop:6469: handleConnectResult: failure - 61
May 23 16:12:13 skelimac.local com.apple.usbmuxd[72]: MuxTCPInputSCE received RST for 0x108-ba128398ed661eee09aa00bf12f69a199bc13141@0xfa120000:10000->0x101a03330-XamarinStudio/com.xamarin.monodevelop:6725: handleConnectResult: failure - 61
May 23 16:12:13 skelimac.local com.apple.usbmuxd[72]: MuxTCPInputSCE received RST for 0x108-ba128398ed661eee09aa00bf12f69a199bc13141@0xfa120000:10000->0x101a03f80-XamarinStudio/com.xamarin.monodevelop:6981: handleConnectResult: failure - 61
May 23 16:12:13 skelimac.local com.apple.usbmuxd[72]: MuxTCPInputSCE received RST for 0x108-ba128398ed661eee09aa00bf12f69a199bc13141@0xfa120000:10000->0x101900790-XamarinStudio/com.xamarin.monodevelop:7237: handleConnectResult: failure - 61
May 23 16:12:13 skelimac.local com.apple.usbmuxd[72]: MuxTCPInputSCE received RST for 0x108-ba128398ed661eee09aa00bf12f69a199bc13141@0xfa120000:10000->0x101900f50-XamarinStudio/com.xamarin.monodevelop:7493: handleConnectResult: failure - 61
May 23 16:12:13 skelimac.local com.apple.usbmuxd[72]: MuxTCPInputSCE received RST for 0x108-ba128398ed661eee09aa00bf12f69a199bc13141@0xfa120000:10000->0x100406990-XamarinStudio/com.xamarin.monodevelop:7749: handleConnectResult: failure - 61
May 23 16:12:13 skelimac.local com.apple.usbmuxd[72]: MuxTCPInputSCE received RST for 0x108-ba128398ed661eee09aa00bf12f69a199bc13141@0xfa120000:10000->0x100406e60-XamarinStudio/com.xamarin.monodevelop:8005: handleConnectResult: failure - 61
May 23 16:12:13 skelimac.local com.apple.usbmuxd[72]: MuxTCPInputSCE received RST for 0x108-ba128398ed661eee09aa00bf12f69a199bc13141@0xfa120000:10000->0x100503f10-XamarinStudio/com.xamarin.monodevelop:8261: handleConnectResult: failure - 61
May 23 16:12:13 skelimac.local com.apple.usbmuxd[72]: MuxTCPInputSCE received RST for 0x108-ba128398ed661eee09aa00bf12f69a199bc13141@0xfa120000:10000->0x100505690-XamarinStudio/com.xamarin.monodevelop:8517: handleConnectResult: failure - 61
May 23 16:12:14 skelimac.local com.apple.usbmuxd[72]: MuxTCPInputSCE received RST for 0x108-ba128398ed661eee09aa00bf12f69a199bc13141@0xfa120000:10000->0x101807410-XamarinStudio/com.xamarin.monodevelop:8773: handleConnectResult: failure - 61
May 23 16:12:14 skelimac.local com.apple.usbmuxd[72]: MuxTCPInputSCE received RST for 0x108-ba128398ed661eee09aa00bf12f69a199bc13141@0xfa120000:10000->0x101806b20-XamarinStudio/com.xamarin.monodevelop:9029: handleConnectResult: failure - 61
Comment 1 Alek Slater 2013-06-07 05:55:33 UTC
Btw, I think this is related to the fact that the debugger doesn't work at all on devices anymore.
I'm surprised not more people are reporting this, its a critical bug.
Comment 2 Rolf Bjarne Kvinge [MSFT] 2013-06-21 03:56:39 UTC
This seems to be a problem with the USB connection between the Mac and the device.

I would try rebooting the device and the mac, and if that doesn't work there are a few more ideas here: http://support.apple.com/kb/TS3694#error14
Comment 3 Alek Slater 2013-06-21 03:59:03 UTC
XCode works without any issues, so I'm not sure your theory is correct.
This issue always crops up after debugging over USB using Xamarin Studio, after 1 deployment, i start seeing millions of these lines in the system log.
Comment 4 Rolf Bjarne Kvinge [MSFT] 2013-07-17 13:40:53 UTC
I found the problem, and it happens when the app fails to start up on the device for some reason (crashes before the debugger can attach for instance).

*** This bug has been marked as a duplicate of bug 12734 ***
Comment 5 Rolf Bjarne Kvinge [MSFT] 2013-07-17 19:22:52 UTC
This has been fixed now.

The Console messages will still show up if Xamarin Studio can't connect to the app, but Xamarin Studio will give up after 2 minutes, or if debugging is stopped (using the Stop button in the IDE).