Bug 12348 - "MapsAndLocationDemo_v2" android sample gives build error.
Summary: "MapsAndLocationDemo_v2" android sample gives build error.
Status: VERIFIED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: Samples ()
Version: 4.7.x
Hardware: PC Mac OS
: Normal normal
Target Milestone: ---
Assignee: Peter Collins
URL:
Depends on:
Blocks:
 
Reported: 2013-05-22 13:33 UTC by Mohit Kheterpal
Modified: 2013-05-23 14:49 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Mohit Kheterpal 2013-05-22 13:33:15 UTC
Steps to Reproduce :

1) Open "MapsAndLocationDemo_v2" android sample in VS/XS
2) Build the application

Expected : Application should build successfully.

Actual : When we build the application then it gives build error.

Below is the build output :
https://gist.github.com/atin360/e0c55c763afcb3314f9f

Environment info :
All Mac and windows
VS 2012 / 2010
XS 4.0.7 (build 3)
MFA 4.7.07004
Mono 2.10.12
Comment 1 Atsushi Eno 2013-05-22 13:52:14 UTC
Are you sure you followed the build steps that pulls the required google_play_services library from your Android SDK setup?
Comment 2 Mohit Kheterpal 2013-05-23 14:49:24 UTC
Today we have checked this sample and followed steps that pulls the required google_play_services library from our Android SDK. 

Now we are able to build and deploy the application successfully. 

Hence closing this issue.