Bug 12339 - On running Android sample 'JniDemo', it gives 3 errors.
Summary: On running Android sample 'JniDemo', it gives 3 errors.
Status: VERIFIED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: Samples ()
Version: 4.7.x
Hardware: PC Windows
: --- normal
Target Milestone: 4.6.7
Assignee: Peter Collins
URL:
Depends on:
Blocks:
 
Reported: 2013-05-22 08:51 UTC by Atin
Modified: 2013-05-22 13:39 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Atin 2013-05-22 08:51:23 UTC
Steps to reproduce:
1. Open 'JniDemo' sample in VS.
2. Debug or run the application.

Actual result:
Application giving 3 errors.
1. Could not copy the file "Resources\drawable-hdpi\icon.png" because it was not found	
2. Could not copy the file "Resources\drawable-ldpi\icon.png" because it was not found
3. Could not copy the file "Resources\drawable-mdpi\icon.png" because it was not found

Build output: https://gist.github.com/atin360/d701c9ba147028bfafc5

Expected result:
Application should run and deploy successfully on device.


Environment details:
Windows 7 and 8
VS 2010/2012
MFA 4.6.07004
Comment 1 Atin 2013-05-22 12:40:53 UTC
An update to the above issue, We have checked this with stable builds:
MFA 4.6.05003
VS 2010/2012
Windows 7 and 8

Regression status: NOT REGRESSION ,We are getting same error.
Comment 2 PJ 2013-05-22 12:54:18 UTC
Fixed in monodroid-samples/6f1e3fe39f51f83c04dd614eb311e26e54bc58e6 (master). Build now succeeds.