Bug 12321 - Unable to connect with the debugger in iPad 5.1.1
Summary: Unable to connect with the debugger in iPad 5.1.1
Status: RESOLVED DUPLICATE of bug 12262
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: 4.0.9 (from master)
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2013-05-21 10:27 UTC by Alek Slater
Modified: 2013-06-24 16:18 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED DUPLICATE of bug 12262

Description Alek Slater 2013-05-21 10:27:10 UTC
In a brand new Solution containing 1 ipad utility project, the app deploys correctly to the device,
but it is unable to connect with the debugger, getting stuck at "Waiting for debugger to connect..."

I'm running Xamarin studio 4.0.8 (build 2) with the following Details:
Xamarin Studio
Version 4.0.8 (build 2)
Installation UUID: 7e85a81a-0dea-4108-8550-b5592e29f602
Runtime:
	Mono 2.10.12 (mono-2-10/c9b270d)
	GTK 2.24.16
	GTK# (2.12.0.0)
	Package version: 210120000

Xamarin.Android
Version: 4.6.6 (Business Edition)
Android SDK: /Users/skela/Library/Developer/Xamarin/android-sdk-mac_x86
	Supported Android versions:
		2.1   (API level 7)
		2.2   (API level 8)
		2.3   (API level 10)
		3.1   (API level 12)
		4.0   (API level 14)
		4.0.3 (API level 15)
		4.1   (API level 16)
		4.2   (API level 17)
Java SDK: /usr

Apple Developer Tools
Xcode 4.6.2 (2067.2)
Build 4H1003

Xamarin.Mac
Xamarin.Mac: Not Installed

Xamarin.iOS
Version: 6.2.5.2 (Business Edition)
Hash: 79bad7e
Branch: 
Build date: 2013-14-05 19:18:45-0400

Build Information
Release ID: 400080002
Git revision: 0a09117dec1aed78c735ac46f7a50ae7d12f7a7a
Build date: 2013-05-16 19:36:29+0000
Xamarin addins: 78d0437c3f92ae13042f81e5fd9487e2c28d5fbc

Operating System
Mac OS X 10.8.3
Darwin skelimac.local 12.3.0 Darwin Kernel Version 12.3.0
    Sun Jan  6 22:37:10 PST 2013
    root:xnu-2050.22.13~1/RELEASE_X86_64 x86_64
========================================

This is the application output:
Please ensure your device is connected...
Connected to: Skelpad
warning MT1106: Could not get list of applications on the device: Request timed out.
warning MT1003: Could not kill the application 'test'. You may have to kill the application manually.
Launching /private/var/mobile/Applications/873403DE-9F09-4EFB-B327-5239CAD65D54/Test.app -debugtrack -monodevelop-port 10000 -connection-mode usb
Comment 1 Jeffrey Stedfast 2013-05-28 15:43:32 UTC
could this be a duplicate of bug #12262?
Comment 2 Jeffrey Stedfast 2013-05-28 16:16:41 UTC

*** This bug has been marked as a duplicate of bug 12262 ***
Comment 3 PJ 2013-06-24 16:18:51 UTC
This bug was marked as fixed for Xamarin Studio 4.0.9, which is currently in the beta channel. Try it out!