Bug 1231 - Fatal error is occurred when user run the Keychain application on iPhone/iPad simulator.
Summary: Fatal error is occurred when user run the Keychain application on iPhone/iPad...
Status: CLOSED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: General ()
Version: 4.9.xx
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-10-04 11:00 UTC by Saurabh
Modified: 2011-10-14 08:41 UTC (History)
5 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Image for the bug (232.80 KB, image/jpeg)
2011-10-04 11:00 UTC, Saurabh
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED FIXED

Description Saurabh 2011-10-04 11:00:36 UTC
Created attachment 580 [details]
Image for the bug

Steps to Reproduce:
1. Download all applications from http://github.com/xamarin/monotouch-samples location
2. Launch the MonoDevelop.
3. Click on "Open an existing solution" link.
4. Select KeyChain Frames application.
5. Click on Open button.
6. Select Debug|iPhone Simulator.
7. Select Build>>Build<Project name>.
8. Select RUN>>iPhone/iPad Simulator.	
 
Actual result:
Fatal error is occurred when user run the application on iPhone/iPad simulator and on Device blank page is displayed.Refer the attached screenshot.

Expected result:
Fatal error should not displayed.

Environments:
MonoDevelop 2.8
MonoTouch 4.9.6
MonoFramework 2.10.5
VM: Parallels desktop
OS: Lion 10.7
Comment 1 Miguel de Icaza [MSFT] 2011-10-04 16:29:25 UTC
Thanks for the bug report, this was fixed on the ios5 branch.

The problem was that when doing a query, we were not retrieving the Data component of it, only the attributes component.   This seems to be a behavior change in iOS itself, as this was working a year ago.
Comment 2 Alex Rønne Petersen 2011-10-05 08:26:20 UTC
Hi,

The sample seems to refuse to run under the simulator. If you run it, if will quickly close, without any error message or anything. Is this expected behavior? If so, why?
Comment 3 Miguel de Icaza [MSFT] 2011-10-05 10:23:50 UTC
It will continue to fail until we have a new release of MonoTouch 5.0 with the fixed backend API.

The sample is not that useful, it could use a little bit of UI to be more informative, meanwhile, replacing QueryAsRecord with QueryAsData would return the password on the second invocation.
Comment 4 Jatin 2011-10-10 07:37:42 UTC
Hi Miguel,

Please let us know if we would be getting an updated version of KeyChain application, that would be compatible with MonoTouch 5.0, so that we can keep a track of this issue and complete its verification after we have updated code for MonoTouch and KeyChain App's version.

Please suggest.

Thanks,
Jatin
Comment 5 Jatin 2011-10-10 10:22:00 UTC
I have validated this issue on MonoTouch 4.9.8 with Xcode 4.2 installed, and now the Fatal error is not appearing. However, the following error is appearing, i.e.

"Socket error while connecting to 127.0.0.1 on port 10001: Connection refused
wait_fences: failed to receive reply: 10004003"

Hence, reopening this issue
Comment 6 Miguel de Icaza [MSFT] 2011-10-10 10:41:15 UTC
Jatin,

This is a new issue.   Could you open a new bug with the steps to reproduce that?

This one is actually a problem
Comment 7 Jatin 2011-10-10 11:47:36 UTC
I have logged a new bug against this issue, i.e. Bug 1396 - Error occurred when user run the Keychain application on iPhone/iPad simulator.

Hence, this issue can be closed.
Comment 8 Atin 2011-10-14 08:41:42 UTC
As per the comments from Miguel New bug has been logged with the ID: 1396.

Hence, closing this issue.