Bug 12309 - "AudioConverterFileConverter" ios sample gives build error.
Summary: "AudioConverterFileConverter" ios sample gives build error.
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Samples ()
Version: 6.2.x
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-05-20 15:01 UTC by Atin
Modified: 2013-06-19 08:33 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Atin 2013-05-20 15:01:15 UTC
Steps to reproduce:
1. Open AudioConverterFileConverter ios sample in X.S.
2. Debug or run the application.

Actual result:
AudioConverterFileConverter giving 2 build errors.

Below is the build output for the same:
https://gist.github.com/anonymous/9ca0df497f05d75abadc

Expected result:
Application should build or run successfully.

Environment details:
All mac
XS 4.0.7 (build 3)- 0f1da1e7f83345a52a4b68b8142ce699a6b2ada0
MT 6.2.6.3
Mono 3.0.11 ((no/edc181c)

App info:
monotouch-samples-masterc0c7874f3ec4277996e2e5b55b440e837ddc1329c0c7874f3ec4277996e2e5b55b440e837ddc1329
Comment 1 PJ 2013-05-21 10:07:19 UTC
I've cherry picked this onto master, the fix was on the master-3.0 branch.
Comment 2 Miguel de Icaza [MSFT] 2013-05-27 06:30:21 UTC
PJ, can we close this bug then?
Comment 3 PJ 2013-05-28 00:14:26 UTC

*** This bug has been marked as a duplicate of bug 11416 ***
Comment 4 narayanp 2013-06-19 08:33:24 UTC
Today we have checked this issue with following builds:

XS 4.0.9(build3)
Xamarin.iOS 6.3.6.76
Mono 3.0.12

Application is working fine. Hence changing the status to verified