Bug 12301 - Compiler references internal Mono types and thus breaks MS .NET runtime compatibility
Summary: Compiler references internal Mono types and thus breaks MS .NET runtime compa...
Status: RESOLVED FIXED
Alias: None
Product: Compilers
Classification: Mono
Component: C# ()
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2013-05-20 04:55 UTC by Mirco Bauer
Modified: 2013-05-21 07:20 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
code to reproduce the issue (1.46 KB, text/plain)
2013-05-20 04:56 UTC, Mirco Bauer
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Mirco Bauer 2013-05-20 04:55:49 UTC
The upcoming Smuxi 0.8.11 started to crash with TypeLoadExceptions on MS .NET. After some investigation I found that tries to load internal types of Mono (e.g. [System.Xml]System.Xml.IHasXmlChildNode). I could make a test-case that leads to this incorrect assembly, see the attachment.

I would be very grateful if there is a known workaround, as this blocks the Smuxi 0.8.11 release.
Comment 1 Mirco Bauer 2013-05-20 04:56:45 UTC
Created attachment 3991 [details]
code to reproduce the issue
Comment 2 Mirco Bauer 2013-05-20 05:36:46 UTC
For the reference, the exception looks like this:
2013-05-19 15:58:10,982 [Main] ERROR Smuxi.Engine.ProtocolManagerFactory - LoadProtocolManager(): GetTypes() on C:\Program Files (x86)\Smuxi\smuxi-engine-xmpp.dll threw exceptions
2013-05-19 15:58:10,983 [Main] ERROR Smuxi.Engine.ProtocolManagerFactory - LoadProtocolManager(): LoaderException: 
System.TypeLoadException: Could not load type 'System.Xml.IHasXmlChildNode' from assembly 'System.Xml, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'.
Comment 3 Marek Safar 2013-05-21 07:20:09 UTC
I cannot reproduce it using master mono.