Bug 12286 - Debugger does not hit breakpoints in anonymous delegates
Summary: Debugger does not hit breakpoints in anonymous delegates
Status: RESOLVED NOT_REPRODUCIBLE
Alias: None
Product: Visual Studio Extensions
Classification: Xamarin
Component: Debugger ()
Version: 1.1.x
Hardware: PC Windows
: Normal major
Target Milestone: ---
Assignee: Vinicius Jarina
URL:
Depends on:
Blocks: 10353 10902
  Show dependency tree
 
Reported: 2013-05-17 12:15 UTC by Goncalo Oliveira
Modified: 2016-05-10 17:01 UTC (History)
8 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED NOT_REPRODUCIBLE

Description Goncalo Oliveira 2013-05-17 12:15:39 UTC
Debugger does not hit on breakpoints if they're inside anonymous delegates.

Example:

BeginInvokeOnMainThread( () =>
{
    int breakpoint_here = 4;
    ...
}


Workaround

BeginInvokeOnMainThread( ThisWorks );

..

void ThisWorks()
{
    int breakpoint_here = 4;
    ...
}
Comment 1 Vinicius Jarina 2013-05-22 18:00:40 UTC
Hello Goncalo Oliveira 

Can you give more details about this issue?

I tested the same code here, and seems to be working. 

http://screencast.com/t/fo0iwjUTcbCb

Thank you.
Comment 2 Goncalo Oliveira 2013-07-09 11:42:43 UTC
Not being able to replicate with 1.2.121. Assuming fixed.