Bug 12257 - 'mdtool build' crashes with NRE
Summary: 'mdtool build' crashes with NRE
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 4.0.6
Hardware: PC Mac OS
: --- normal
Target Milestone: 4.0.9 (from master)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-05-15 19:41 UTC by Eric Fikus
Modified: 2013-06-24 16:18 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
mdtool output (2.48 KB, text/plain)
2013-05-15 19:41 UTC, Eric Fikus
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Eric Fikus 2013-05-15 19:41:37 UTC
Created attachment 3973 [details]
mdtool output

The mdtool included with Xamarin Studio 4.0.6 is crashing with a NullReferenceException trying to run a clean.

Object reference not set to an instance of an object
FATAL ERROR [2013-05-15 16:34:19Z]: System.NullReferenceException: Object reference not set to an instance of an object
  at MonoDevelop.Projects.BuildTool.Run (System.String[] arguments) [0x002db] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-4.0.6-branch/da8a8e9d/source/monodevelop/main/src/core/MonoDevelop.Core/MonoDevelop.Projects/BuildTool.cs:145 
  at MonoDevelop.Core.ApplicationService.StartApplication (System.String appId, System.String[] parameters) [0x0004c] in /Users/builder/data/lanes/monodevelop-lion-monodevelop-4.0.6-branch/da8a8e9d/source/monodevelop/main/src/core/MonoDevelop.Core/MonoDevelop.Core/ApplicationService.cs:50 
make: *** [Clean] Error 255

Full output is attached.
Comment 1 Jeffrey Stedfast 2013-05-16 14:52:19 UTC
fixed in git master, we'll be rolling out a 4.0.8 hotfix soon with the patch
Comment 2 PJ 2013-06-24 16:18:45 UTC
This bug was marked as fixed for Xamarin Studio 4.0.9, which is currently in the beta channel. Try it out!