Bug 12220 - After deleting files documentation wizard pop up does not appear.
Summary: After deleting files documentation wizard pop up does not appear.
Status: VERIFIED INVALID
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Documentation ()
Version: 4.0.6
Hardware: PC Mac OS
: --- normal
Target Milestone: 4.0.6
Assignee: Jérémie Laval
URL:
Depends on:
Blocks:
 
Reported: 2013-05-13 10:22 UTC by Atin
Modified: 2013-05-15 06:12 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED INVALID

Description Atin 2013-05-13 10:22:35 UTC
Steps to reproduce:
1. MonoTouch should be installed
1. Delete com.apple.adc.documentation.AppleiOS5_0.iOSLibrary.docset from path      com.apple.adc.documentation.AppleiOS5_0.iOSLibrary.docset.
2. Delete apple-doc-wizard.sh from Developer/MonoTouch/usr/share/doc/MonoTouch
3. Go to Help->click on help.

Actual result:
After deleting these files go to help->click on help then user is not prompted to documentation wizard pop up.

Expected result:
User should prompt to documentation wizard pop up.

Environment details:
All mac
XS 4.0.6 (build 3)- fd96c44d878d1e176954e062c9ee658c6fe7d47b
MT 6.3.5.42
Mono 3.0.11 ((no/edc181c)
Comment 1 PJ 2013-05-13 10:25:50 UTC
Not sure why you're doing step 2. Can you confirm that this happens without performing step 2?
Comment 2 Atin 2013-05-13 10:40:35 UTC
An update to the above issue , We have also checked it without deleting step 2
We are seeing same behaviour here.
Comment 3 PJ 2013-05-13 11:58:35 UTC
I also see this behavior. Perhaps the merge-reset steps have changed. I'll have to check with Jeremie when he gets in today.

Also, the MonoDoc stuff is Xamarin Studio, not iOS (for future reference).
Comment 4 PJ 2013-05-13 12:37:34 UTC
So yeah, deleting the Apple documentation was not a sufficient condition for triggering the merge, so this bug is invalid.

The condition that should be triggering the merge here is that there is no merge.status.


RESOLVEing this one as INVALID. 


Jeremie is committing the fixes right now, so you can re-test with the next 4.0.6 build. 

Thanks!
Comment 5 Atin 2013-05-15 06:12:16 UTC
As per comment 4 marked this as Verified Invalid.