Bug 12219 - Device menu changes back to iPhone simulator after every successful build
Summary: Device menu changes back to iPhone simulator after every successful build
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: iOS add-in ()
Version: 4.0.5
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: master
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2013-05-13 10:05 UTC by Owen Stewart
Modified: 2013-08-05 12:45 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Owen Stewart 2013-05-13 10:05:41 UTC
Open Xamarin Studio
Select project
Choose iPad simulator
Build project
Ipad simulator opens
Hit stop
Target drop down changes automatically to iPhone simulator
If you don't notice and press play the iPhone simulator will open 

Subsequent (successful) builds also change the disabled drop down back to iPhone simulator as the simulator launches

It's really annoying if you're trying to debug anything. At least the old bug you just had to remember to reselect the correct simulator the first time Xamarin studio opened and then it remembered your choice until restart.
Comment 1 Jeffrey Stedfast 2013-05-16 12:39:13 UTC
I've been trying all week to reproduce this and I simply cannot. It never switches on me.

Please tell me what I am doing differently/wrong: http://screencast.com/t/J8hZ39O4HE
Comment 2 Jeffrey Stedfast 2013-08-05 12:45:34 UTC
this was likely related to bug #12260 which was fixed