Bug 12191 - When saving using ^S the cursor is moved to the top of the file
Summary: When saving using ^S the cursor is moved to the top of the file
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 4.0.3
Hardware: PC Windows
: --- normal
Target Milestone: 4.0.9 (from master)
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2013-05-10 08:27 UTC by bartwe
Modified: 2013-12-16 10:50 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description bartwe 2013-05-10 08:27:59 UTC
When editing a file and manually saving using ^S the cursor is moved to the top of the screen.
Comment 1 Mike Krüger 2013-05-12 03:41:22 UTC
I think you've turned on format before save ?

Then this has been fixed.
Comment 2 bartwe 2013-05-12 04:44:56 UTC
Ah right.
I've switched to the beta 4.0.5(4) release, issue is there too, which version has the fix ?
Comment 3 Mike Krüger 2013-05-12 04:48:15 UTC
Good question - it works in master. I thought that 4.0.5 has it.
Comment 4 PJ 2013-06-24 16:18:35 UTC
This bug was marked as fixed for Xamarin Studio 4.0.9, which is currently in the beta channel. Try it out!
Comment 5 tharealjohn 2013-12-16 10:50:32 UTC
I am using 4.3.0 in the alpha channel, and this bug is still present. Turning off cold folding for regions and comments seems to stop this from happening.
Comment 6 tharealjohn 2013-12-16 10:50:56 UTC
Code folding*