Bug 12158 - SVN Exception - SubversionException: Commit failed
Summary: SVN Exception - SubversionException: Commit failed
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Version Control ()
Version: 4.0.3
Hardware: PC Mac OS
: High normal
Target Milestone: master
Assignee: Marius Ungureanu
URL:
Depends on:
Blocks:
 
Reported: 2013-05-08 05:28 UTC by Prashant Cholachagudda
Modified: 2013-07-12 06:30 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Prashant Cholachagudda 2013-05-08 05:28:17 UTC
Getting consistent errors when checking.

MonoDevelop.VersionControl.Subversion.SubversionException: Commit failed (details follow):

at MonoDevelop.VersionControl.Subversion.Unix.SvnClient.CheckError (IntPtr error, Nullable`1 allowedError) [0x0007b] in /Users/builder/data/lanes/monodevelop-lion-evolve_fixed/a8bf58d3/source/monodevelop/main/src/addins/VersionControl/MonoDevelop.VersionControl.Subversion.Unix/MonoDevelop.VersionControl.Subversion.Unix/SvnClient.cs:45

at MonoDevelop.VersionControl.Subversion.Unix.SvnClient.CheckError (IntPtr error) [0x00000] in /Users/builder/data/lanes/monodevelop-lion-evolve_fixed/a8bf58d3/source/monodevelop/main/src/addins/VersionControl/MonoDevelop.VersionControl.Subversion.Unix/MonoDevelop.VersionControl.Subversion.Unix/SvnClient.cs:25

at MonoDevelop.VersionControl.Subversion.Unix.UnixSvnBackend.CheckError (IntPtr error) [0x00000] in /Users/builder/data/lanes/monodevelop-lion-evolve_fixed/a8bf58d3/source/monodevelop/main/src/addins/VersionControl/MonoDevelop.VersionControl.Subversion.Unix/MonoDevelop.VersionControl.Subversion.Unix/SvnClient.cs:172

at MonoDevelop.VersionControl.Subversion.Unix.UnixSvnBackend.Commit (MonoDevelop.Core.FilePath[] paths, System.String message, IProgressMonitor monitor) [0x000b9] in /Users/builder/data/lanes/monodevelop-lion-evolve_fixed/a8bf58d3/source/monodevelop/main/src/addins/VersionControl/MonoDevelop.VersionControl.Subversion.Unix/MonoDevelop.VersionControl.Subversion.Unix/SvnClient.cs:761

at MonoDevelop.VersionControl.Subversion.SubversionRepository.OnCommit (MonoDevelop.VersionControl.ChangeSet changeSet, IProgressMonitor monitor) [0x00047] in /Users/builder/data/lanes/monodevelop-lion-evolve_fixed/a8bf58d3/source/monodevelop/main/src/addins/VersionControl/MonoDevelop.VersionControl.Subversion/MonoDevelop.VersionControl.Subversion/SubversionRepository.cs:200

at MonoDevelop.VersionControl.Repository.Commit (MonoDevelop.VersionControl.ChangeSet changeSet, IProgressMonitor monitor) [0x0000c] in /Users/builder/data/lanes/monodevelop-lion-evolve_fixed/a8bf58d3/source/monodevelop/main/src/addins/VersionControl/MonoDevelop.VersionControl/MonoDevelop.VersionControl/Repository.cs:416

at MonoDevelop.VersionControl.CommitCommand+CommitWorker.Run () [0x00028] in /Users/builder/data/lanes/monodevelop-lion-evolve_fixed/a8bf58d3/source/monodevelop/main/src/addins/VersionControl/MonoDevelop.VersionControl/MonoDevelop.VersionControl/CommitCommand.cs:102
Comment 2 BB 2013-05-21 15:24:06 UTC
I also get this consistently on my project (on Mac mini). Any workarounds or news for when it will be fixed? It's causing major headaches
Comment 3 Marius Ungureanu 2013-06-28 04:56:49 UTC
I can't seem to be able to reproduce this. Any tips on how to?
Comment 4 Marius Ungureanu 2013-06-28 05:04:31 UTC
It could be that your subversion client might have cached the details.

You can find cached data in ~/.subversion/auth/.

Try removing the specific files from inside those folders. (Depending on what kind of connection you used). XS doesn't cache anything by itself.
Comment 5 Marius Ungureanu 2013-07-05 06:13:22 UTC
Hey, can you test with the new MD master? Exceptions now give detailed information on SVN, and it would help me, since I haven't been able to reproduce it yet.

Thanks!
Comment 6 Marius Ungureanu 2013-07-12 06:30:30 UTC
A fix has been applied for this. It will be included in upcoming releases.