Bug 12151 - Toggle Line Comments Hotkeys
Summary: Toggle Line Comments Hotkeys
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 4.0.3
Hardware: PC Windows
: Low normal
Target Milestone: 4.0.9 (from master)
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2013-05-07 23:21 UTC by Tormentor
Modified: 2013-06-24 16:18 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Tormentor 2013-05-07 23:21:39 UTC
Visual Studio Key Bindings chosen from Tools | Options

Edit a .CS file.

Select several commented lines, or select several uncommented lines.

Ctrl K | C should Toggle Line Comments.  The hotkey combination does not work.

If you right-click, and choose Toggle Line Comments from the context menu, it works fine.  The context menu item even properly reports that the hotkey combination in this binding would be CTRL+K|C, but they don't actually work.
Comment 1 Mikayla Hutchinson [MSFT] 2013-05-08 13:50:39 UTC
The hotkey works, the problem is that it doesn't match VS. VS has Ctrl-K|Ctrl-C.
Comment 3 Mike Krüger 2013-05-10 03:41:07 UTC
fixed
Comment 4 PJ 2013-06-24 16:18:39 UTC
This bug was marked as fixed for Xamarin Studio 4.0.9, which is currently in the beta channel. Try it out!