Bug 12122 - Activation loops when building a project with --keeptemp as a trial user
Summary: Activation loops when building a project with --keeptemp as a trial user
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Tools ()
Version: 6.3.x
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-05-06 13:02 UTC by Saurabh
Modified: 2013-11-14 11:10 UTC (History)
7 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Comment 1 PJ 2013-05-06 13:10:05 UTC
I can reproduce, but this seems to be restricted to --keeptemp.

With LLVM set (another project option restriction) it seems totally fine. I'd like to figure out why this is looping though.
Comment 3 PJ 2013-05-07 12:54:23 UTC
Heh yep Sebastien, silly me (we have cases for it, it just slipped my mind).
Comment 4 Jeffrey Stedfast 2013-11-06 15:12:30 UTC
Maybe mhutch's new workflows fix this?
Comment 9 Saurabh 2013-11-14 11:10:48 UTC
We have checked this issue with latest builds:

Xamarin Studio Version 4.2.1 (build 1)
Xamarin.iOS Version: 7.0.4.209

Now, On building "MT9004" project with trial license, it just activates license one time and then gives error "Error MT9004: Option `--keeptemp` requires non-trial Business (or higher) license.".

So, now it does not stuck in loop activation with trial license.

Screencast: http://screencast.com/t/yJOIoopcriSj


Hence, closing this issue.