Bug 12102 - [GTK] Graphics distortion
Summary: [GTK] Graphics distortion
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: 4.0.4
Hardware: PC Mac OS
: Normal normal
Target Milestone: master
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-05-05 07:08 UTC by Willem Meints
Modified: 2013-09-11 09:21 UTC (History)
6 users (show)

Tags: gtk
Is this bug a regression?: ---
Last known good build:


Attachments
Screenshot demonstrating the problem (1.37 MB, image/png)
2013-05-05 07:08 UTC, Willem Meints
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Willem Meints 2013-05-05 07:08:40 UTC
Created attachment 3915 [details]
Screenshot demonstrating the problem

When I start to debug using the Android debugger, the graphics in Xamarin Studio start to get distorted when I move my mouse over the Xamarin studio window. After restarting Xamarin Studio, the effect is gone. However as soon as I restart the emulator AFTER I have started Xamarin studio, the distortion effect is back.

I have attached a screenshot to demonstrate the problem.
Comment 1 Mikayla Hutchinson [MSFT] 2013-05-05 18:16:08 UTC
It's looks like our native graphics surface is getting corrupted. Does this happen with other apps or just Xamarin Studio?
Comment 2 Willem Meints 2013-05-06 02:47:28 UTC
It only happens in Xamarin studio (at least so far).
Comment 3 Kristian Rietveld (inactive) 2013-05-07 04:58:14 UTC
Could have to do with how we deal with CALayers?  The distortion looks a bit like some initial distortion we saw in the past.  That doesn't mean that the distortions are the "same" though :)
Comment 4 Kristian Rietveld (inactive) 2013-06-01 06:41:27 UTC
When I launch the Android emulator (from command line) while Xamarin Studio is running, nothing special happens for me.

Additional information is required to debug this issue, I have the following questions:

  1) Does the distortion also occur if the Android emulator is launched from the command line? Or does the distortion only occur if the Android emulator is launched from Xamarin Studio?

 2) Does a graphics-related warning or error show up in the system logs? You can view system log messages using Console.app that is installed by default on Mac OS X.
Comment 5 Lluis Sanchez 2013-09-11 09:21:10 UTC
This should be already fixed. Please reopen if you see the problem again.