Bug 12073 - [iPhone5] Labels not displayed properly for iOS Sample 'Touch'
Summary: [iPhone5] Labels not displayed properly for iOS Sample 'Touch'
Status: VERIFIED FIXED
Alias: None
Product: iOS
Classification: Xamarin
Component: Samples ()
Version: 6.2.x
Hardware: PC Mac OS
: --- normal
Target Milestone: Untriaged
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-05-02 09:18 UTC by Saurabh
Modified: 2013-06-03 06:10 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Labels of Touches (64.73 KB, image/png)
2013-05-02 09:18 UTC, Saurabh
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Saurabh 2013-05-02 09:18:59 UTC
Created attachment 3907 [details]
Labels of Touches

Steps to reproduce:
1. Open iOS Sample 'Touch'.
2. Debug or Run the sample on iPhone5.
3. Observe that application deployed and launched on device.

Actual Result: When user deploy and launch application on device(iPone5), All three labels 'Drag Me', 'Touch Me' and 'Double Tap Me' not displayed properly and 'Touch Me','Double Tap Me' overlapped. While on other devices (iPhone4, iPhone4S) and Simulator, labels displayed properly. However, when we change the layout, all labels get removed.

Expected Result: All labels should displayed properly.

Device info:
iPhone5
Version 6.0.2

Environment details:
All mac
XS 4.0.4 (build 2)- a8bf58d398a13bcc7595f5f85adae04865a834d4
MT 6.2.5.0
Mono 2.10.12 (mono-2-10/c9b270d)

Note: We have attached image of iPhone5 for this issue.

App info:
monotouch-samples-masterb3e630e561a77c3b4ad499699607e5eba11d26c2/Touch
Comment 1 PJ 2013-05-02 10:51:26 UTC
Did this sample look ok previously on iPhone 5? Is this a regression?
Comment 2 Saurabh 2013-05-02 14:42:45 UTC
No it is not a regression, Same behavior was seen before.
Comment 3 Bo Pang 2013-05-29 12:27:02 UTC
Fixed in monotouch-samples e76ebd435589367e4d6638721c81eb19c6025281
Comment 4 Saurabh 2013-06-03 06:10:19 UTC
Today, we have checked this issue with following build:

XS 4.0.8(build 2)
MT 6.2.6.6
Mono 2.10.12
App info: monotouch-samples-master-7c7195b7c07157addf7f6a37ae29fce072ca3346.zip
iphone 5

Now , All three labels are displaying properly on iphone 5 device . Hence marking this as Verified Fixed.