Bug 12057 - Command+A doesn't Select All in Watch or Locals pads
Summary: Command+A doesn't Select All in Watch or Locals pads
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: 4.0.3
Hardware: PC Mac OS
: Normal normal
Target Milestone: 4.0.6
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks:
 
Reported: 2013-05-01 12:37 UTC by Chris Hamons
Modified: 2013-05-03 20:08 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Chris Hamons 2013-05-01 12:37:29 UTC
If you have multiple watch window elements that you want to delete (since they take so long to update on each breakpoint), command + A does not select them all (like other things on the mac). However, you can work around this with holding shift and then holding down. However, when you hit delete it doesn't delete all the watch elements, just one at a time. This seems wrong.
Comment 1 Jeffrey Stedfast 2013-05-03 18:02:08 UTC
The Delete issue has been fixed (when I fixed this for one of the other pads for one of your other bug reports, I went around and fixed it for all of the debugger pads), but it looks like Command+A doesn't Select All, so that's still an issue.
Comment 2 Marius Ungureanu 2013-05-03 18:35:20 UTC
Confirmed to happen on Windows with Control+A. This seems to be a general GTK TreeView issue than specific to this pad.
Comment 3 Jeffrey Stedfast 2013-05-03 20:08:14 UTC
implemented in git master (should show up in Xamarin Studio 4.0.6 or so)