Bug 12051 - Added asset to the android application are not displaying after running application.
Summary: Added asset to the android application are not displaying after running appli...
Status: VERIFIED INVALID
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Android Add-in ()
Version: 4.0.4
Hardware: All Mac OS
: --- normal
Target Milestone: ---
Assignee: Mikayla Hutchinson [MSFT]
URL: http://docs.xamarin.com/guides/andro...
Depends on:
Blocks:
 
Reported: 2013-05-01 07:35 UTC by Atin
Modified: 2013-05-13 02:54 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED INVALID

Description Atin 2013-05-01 07:35:08 UTC
Steps to reproduce:
1. Create any android application.
2. Go in the "Assets" folder of your project.
3. Add a new text file to this folder called "read_asset.txt"and Place some text in it like "I came from an asset".
4. Set the BuildAction to AndroidAsset
5. Debug or run the application.

Actual result:
Asset is not displaying on device or emulator.However application is launched successfully.

Expected result:
User should able to user can add asset to the project and it should display on Application.

Environment details:
All mac and Windows
VS 2010/2012
XS 4.0.4 (build 2)- a8bf58d398a13bcc7595f5f85adae04865a834d4
MFA 4.7.4-14

Note: We have use following documents for adding a Asset to the android application.
http://docs.xamarin.com/guides/android/advanced_topics/using_android_assets
Comment 1 Mikayla Hutchinson [MSFT] 2013-05-01 11:57:07 UTC
Assets are not automatically displayed, they're just included in your app, so you can access them from code. The example you linked uses code to load and display the asset, which your repro steps do not do.
Comment 2 narayanp 2013-05-13 02:54:03 UTC
As per comment#1 changing the status to Verified