Bug 12022 - User is not able to build MFA templates on VS2010
Summary: User is not able to build MFA templates on VS2010
Status: VERIFIED FIXED
Alias: None
Product: Android
Classification: Xamarin
Component: General ()
Version: 4.7.x
Hardware: PC Windows
: High critical
Target Milestone: 4.8 (async)
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2013-04-29 08:53 UTC by Atin
Modified: 2013-05-13 09:48 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
VERIFIED FIXED

Description Atin 2013-04-29 08:53:35 UTC
Steps to reproduce:
1. Open VS.
2. Create any MFA application.
3. Build the application.

Actual result:
User is not able to build MFA application.

Below is the build output for the same:
https://gist.github.com/atin360/808d03b1d4901b30e83a

Expected result:
User should able to build or run the MFA application.

Environment details:
Windows 7 and 8
VS 2010
MFA 4.7.05086

Note: On VS 2012 we are able to successfully build the application
Comment 1 Jonathan Pryor 2013-04-30 20:23:20 UTC
This is bizarre, as only one version of Xamarin.AndroidTools.dll is present in the .msi (at least if I'm reading Product.wxs properly). How could MonoDroidSdk.get_CommonAssemblyPath() be found in VS2012 but not VS2010?

(Or is VS2010 using some different code path that doesn't involve MonoDroidSdk.get_CommonAssemblyPath()? That doesn't make much sense either.)

In any event, should be fixed in monodroid/e27c3d7d, as that removes use of the MonoDroidSdk.CommonAssemblyPath property.
Comment 2 Nischal 2013-05-13 09:48:42 UTC
Today we have checked this issue with following builds:

VS 2010/2012
Xamarin.Android 4.7.5-141

We are successfully able to build MFA templates application. Changing the status to Verified