Bug 11996 - CS0584: Internal compiler error: Object reference not set to an instance of an object
Summary: CS0584: Internal compiler error: Object reference not set to an instance of a...
Status: RESOLVED FIXED
Alias: None
Product: Compilers
Classification: Mono
Component: C# ()
Version: unspecified
Hardware: PC Linux
: --- normal
Target Milestone: ---
Assignee: Marek Safar
URL:
Depends on:
Blocks:
 
Reported: 2013-04-26 17:50 UTC by delcypher
Modified: 2013-04-29 18:54 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Output of xbuild during failed compilation (11.21 KB, text/x-log)
2013-04-26 17:50 UTC, delcypher
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description delcypher 2013-04-26 17:50:16 UTC
Created attachment 3883 [details]
Output of xbuild during failed compilation

3.x Builds of Mono do not seem to be able to compile a small(ish) project that I've just started playing with

I'm using the most recent build of mono from github (edc181c514ddc082ce44cde69f2272a12e942b88) on my Arch Linux system (although I'm not using any of Arch Linux's mono packages)

To reproduce run:
$ hg clone https://hg.codeplex.com/boogie
$ cd boogie/Source
$ xbuild /p:TargetFrameworkProfile="" Boogie.sln 

I've attached the log of the output of xbuild but the errors that appear are essentially:

        BoogieDriver.cs(653,59): error CS0584: Internal compiler error: Object reference not set to an instance of an object
        BoogieDriver.cs(654,59): error CS0584: Internal compiler error: Object reference not set to an instance of an object
        BoogieDriver.cs(655,56): error CS0584: Internal compiler error: Object reference not set to an instance of an object

This project builds successfully under my distribution's older version of mono (2.10.8 https://www.archlinux.org/packages/extra/x86_64/mono/) but does not seem to on the newer mono builds.

The expressions that seem to be causing the trouble are:
new Houdini.IndependentAttribute<Houdini.HoudiniConst>()
new Houdini.IndependentAttribute<Houdini.ConstantProp>()
new Houdini.IndependentAttribute<Houdini.Intervals>(

I apologise for not being able to produce a better test case. I tried copying portions of the code that I thought was causing the problem to make a test case but that did not reproduce the problem.
Comment 1 Marek Safar 2013-04-29 11:48:29 UTC
Thanks for the bug report.

Fixed in master
Comment 2 delcypher 2013-04-29 18:54:44 UTC
Thanks for prompt response. The "Boogie" project now compiles correctly, thanks.