Bug 11977 - Can't run on device when project sets BaseIntermediateOutputPath
Summary: Can't run on device when project sets BaseIntermediateOutputPath
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Android Add-in ()
Version: 4.0.4
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Mikayla Hutchinson [MSFT]
URL:
: 12064 ()
Depends on:
Blocks:
 
Reported: 2013-04-25 17:28 UTC by jesse.attas
Modified: 2013-05-03 19:31 UTC (History)
3 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description jesse.attas 2013-04-25 17:28:53 UTC
I want to set the BaseIntermediateOutputPath variable in my projects to something besides "obj". But when I do this, I am no longer able to run Release or Debug builds on my device. After build and deployment succeed, the status area at the top of Xamarin Studio reports the error "Intermediate manifest file is missing".

To reproduce, create a new Android Application project, edit the csproj file by adding this line after AssemblyName in the first PropertyGroup:
    <BaseIntermediateOutputPath>obj.MonoDroid</BaseIntermediateOutputPath>
Then reload the project in Xamarin Studio and try to run it on a device.
Comment 1 Mikayla Hutchinson [MSFT] 2013-04-29 17:42:26 UTC
Fixed.
Comment 2 Mikayla Hutchinson [MSFT] 2013-05-03 19:31:39 UTC
*** Bug 12064 has been marked as a duplicate of this bug. ***