Bug 11970 - XS ignores underscores (_) in project path
Summary: XS ignores underscores (_) in project path
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Project Model ()
Version: 4.0.4
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Lluis Sanchez
URL:
Depends on:
Blocks:
 
Reported: 2013-04-25 14:57 UTC by Bryan Moulton
Modified: 2013-05-21 10:34 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Bryan Moulton 2013-04-25 14:57:45 UTC
In reference to case #33127

When adding or removing a project in Xamarin Studio, projects with underscore(s) in the path will have these removed. XS is then unable to find these project files because of the bad path.

/Users/<username>/Documents/Projects/01_Projects/00_Test/trunk/TestiOS.sln

Shows up as

/Users/<username>/Documents/Projects/01Projects/00Test/trunk/TestiOS.sln
Comment 1 Lluis Sanchez 2013-05-21 10:32:58 UTC
This was a display issue in the error dialog.
Comment 2 Lluis Sanchez 2013-05-21 10:34:16 UTC
That is, MonoDevelop can handle paths with underscores just fine. MD was crashing elsewhere and showing the error dialog with the project path, which was shown without the underscores.