Bug 11967 - Dropdown Targets Off After Scrolling
Summary: Dropdown Targets Off After Scrolling
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Text Editor ()
Version: 4.0.4
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Mike Krüger
URL:
Depends on:
Blocks:
 
Reported: 2013-04-25 11:38 UTC by Kevin Mullins
Modified: 2013-08-19 05:07 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
Screenshot showing error in scroll position (51.33 KB, image/png)
2013-07-01 12:40 UTC, Randy
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Kevin Mullins 2013-04-25 11:38:26 UTC
On any of the dropdown boxes in the Text Editor area (for example selecting the name of a function declared in the code you are editing), if the box scrolls the cursor is off by more than half a step and it makes it hard to actually select an item in the list... you'll usually end up either selecting the item before or after the one you are actually going for.
Comment 1 Mike Krüger 2013-05-03 04:48:52 UTC
Can you make a screencast ?
Comment 2 Randy 2013-07-01 12:40:07 UTC
I've had the same problem for some time since the release of the IDE back in Feb. I reported it once but can't find the old bug report. 

It appears the combo box is forcing the display to show only complete text lines but the current scroll position is actually at a partial line position. The code that determines which line is being pointed at is using the real scroll position instead of the 'rounded down' position used to determine where to draw the text.

To test, you have to get the scroll position somewhere in the middle. At the start or end will always work correctly. The amount of roundoff error will vary with different scroll positions.

---

As a separate issue, the combobox used to be much larger but was changed to just 8 lines of text with the big UI update. See screenshot
Comment 3 Randy 2013-07-01 12:40:58 UTC
Created attachment 4245 [details]
Screenshot showing error in scroll position
Comment 4 Mike Krüger 2013-08-19 05:07:20 UTC
fixed