Bug 11940 - Sometimes on breakpoints "Thread started:" continuously prints when at breakpoint debugging Xam.Mac app
Summary: Sometimes on breakpoints "Thread started:" continuously prints when at breakp...
Status: RESOLVED FIXED
Alias: None
Product: Runtime
Classification: Mono
Component: Debugger ()
Version: unspecified
Hardware: PC Mac OS
: --- normal
Target Milestone: ---
Assignee: Zoltan Varga
URL:
Depends on:
Blocks:
 
Reported: 2013-04-24 13:04 UTC by Chris Hamons
Modified: 2013-04-25 19:36 UTC (History)
4 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:


Attachments
First stack trace (53.61 KB, text/plain)
2013-04-24 13:04 UTC, Chris Hamons
Details
Stack trace a few seconds later. (26.73 KB, text/plain)
2013-04-24 13:04 UTC, Chris Hamons
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on GitHub or Developer Community with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Chris Hamons 2013-04-24 13:04:09 UTC
Created attachment 3867 [details]
First stack trace

Sometimes when I hit a breakpoint, the application output fills up with "Thread started:" over and over. 

I'm attaching two stack traces from gdb, a few seconds apart.
Comment 1 Chris Hamons 2013-04-24 13:04:24 UTC
Created attachment 3868 [details]
Stack trace a few seconds later.
Comment 2 Jeffrey Stedfast 2013-04-25 17:11:26 UTC
Zoltan: any ideas on this one? Seems like the runtime is emitting the ThreadStart event?
Comment 3 Zoltan Varga 2013-04-25 18:47:59 UTC
Probably a dup of:
https://bugzilla.xamarin.com/show_bug.cgi?id=6452
Comment 4 Zoltan Varga 2013-04-25 19:36:37 UTC
Should be fixed in master/2.10.