Bug 11936 - Build errors and warnings accumulated in between builds
Summary: Build errors and warnings accumulated in between builds
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Android Add-in ()
Version: 4.0.6
Hardware: Macintosh Mac OS
: Normal normal
Target Milestone: ---
Assignee: Mikayla Hutchinson [MSFT]
URL:
: 11935 11951 ()
Depends on:
Blocks:
 
Reported: 2013-04-24 09:08 UTC by Kent Fonager
Modified: 2013-05-29 12:32 UTC (History)
7 users (show)

Tags: papercut
Is this bug a regression?: ---
Last known good build:


Attachments
Output from Xamarin Studio after succesfull build (42.35 KB, image/png)
2013-04-24 09:08 UTC, Kent Fonager
Details


Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Kent Fonager 2013-04-24 09:08:36 UTC
Created attachment 3864 [details]
Output from Xamarin Studio after succesfull build

I'm using Xamarin Studio 4.0.4 and Mono for Android 4.6.4.

Everytime a do a build, the error and warnings are accumulated, instead of being reset in between each build, as expected. Please see the attached screenshot stating that the Build was a success, but still it says 54 errors and 9281 warnings.

The same way as these errors and warnings are not reset, the same errors and warnings a "stuck" in the editor. When an errors shows up, the "error bubble" is showing info about the error. But after fixing the error and doing a build with succes, the error (or warning) bubble is still being shown i the editor.

I have tried to do a "clean all", but that does not change or reset the errors and warnings.
Comment 1 Peter Collins 2013-05-14 13:37:34 UTC
*** Bug 11935 has been marked as a duplicate of this bug. ***
Comment 2 Peter Collins 2013-05-14 14:10:42 UTC
I am seeing this warning accumulation / duplication on our current stables with Android projects, but not iOS projects. However I am not able to reproduce this when building from command line. CCing mhutch, as this may be an X.S. issue.

As far as error duplication / accumulation, I was unable to reproduce. Kent, is there any chance you could attach a small sample project that displays this behavior?

Steps to reproduce:
http://screencast.com/t/EiedJXC9a27k
1) Create a new X.A. template.
2) Attempt to deploy to device / emulator.
3) Cancel deployment instead of selecting a target device.
4) Repeat steps 2 & 3.

Environment Details:
OSX 10.8.3
X.S. 4.0.5 - build 4 (5c86fd4)
Mono 2.10.12 (mono-2-10/c9b270d)
X.A. 4.6.4 (03814ac5)
Comment 3 Rodrigo Kumpera 2013-05-22 15:29:12 UTC
*** Bug 11951 has been marked as a duplicate of this bug. ***
Comment 4 Mikayla Hutchinson [MSFT] 2013-05-23 17:46:04 UTC
Should be fixed by monodevelop/5ef6eb5, need to check.
Comment 5 Mikayla Hutchinson [MSFT] 2013-05-29 12:32:11 UTC
Confirmed, this is now fixed.