Bug 11909 - Constants are not recognised by debugger
Summary: Constants are not recognised by debugger
Status: RESOLVED FIXED
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: Debugger ()
Version: unspecified
Hardware: PC Mac OS
: Low enhancement
Target Milestone: ---
Assignee: Jeffrey Stedfast
URL:
Depends on:
Blocks: 8514
  Show dependency tree
 
Reported: 2013-04-23 12:09 UTC by Marek Safar
Modified: 2014-06-11 16:08 UTC (History)
1 user (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
RESOLVED FIXED

Description Marek Safar 2013-04-23 12:09:39 UTC
using System;
using System.IO;

public class mono_filestream_bug
{
	public static void Main ()
	{
		const int pos = 1;
		const int bufferSize = 128;

		var a = pos + 1; // Hover over pos and MD says pos is unknown identifier
		return;
	}
}
Comment 1 Jeffrey Stedfast 2013-05-14 13:29:10 UTC
fixed in git master
Comment 2 Mikayla Hutchinson [MSFT] 2013-07-08 16:55:45 UTC
This works for tooltips but not for the watch or immediate windows.
Comment 3 Jeffrey Stedfast 2013-07-08 17:36:35 UTC
it will be non-trivial to make it work for those pads :(
Comment 4 Jeffrey Stedfast 2014-06-11 16:08:56 UTC
the original bug is fixed