Bug 1185 - After click on Run With, there is only only one option available.
Summary: After click on Run With, there is only only one option available.
Status: CLOSED NOT_REPRODUCIBLE
Alias: None
Product: Xamarin Studio
Classification: Desktop
Component: General ()
Version: unspecified
Hardware: Macintosh Mac OS
: --- normal
Target Milestone: ---
Assignee: Bugzilla
URL:
Depends on:
Blocks:
 
Reported: 2011-10-03 07:29 UTC by Jatin
Modified: 2011-10-11 02:33 UTC (History)
2 users (show)

Tags:
Is this bug a regression?: ---
Last known good build:

Notice (2018-05-24): bugzilla.xamarin.com is now in read-only mode.

Please join us on Visual Studio Developer Community and in the Xamarin and Mono organizations on GitHub to continue tracking issues. Bugzilla will remain available for reference in read-only mode. We will continue to work on open Bugzilla bugs, copy them to the new locations as needed for follow-up, and add the new items under Related Links.

Our sincere thanks to everyone who has contributed on this bug tracker over the years. Thanks also for your understanding as we make these adjustments and improvements for the future.


Please create a new report on Developer Community or GitHub with your current version information, steps to reproduce, and relevant error messages or log files if you are hitting an issue that looks similar to this resolved bug and you do not yet see a matching new report.

Related Links:
Status:
CLOSED NOT_REPRODUCIBLE

Description Jatin 2011-10-03 07:29:15 UTC
Steps to reproduce:

1. Launch the MonoDevelop 2.8 Beta 3.
2. Start a New Solution or Open the Existing Solution.
3. Solution sidebar appears at the left panel.
4. Right Click over the project.
5. Click on the option "Run With".
6. There is only one option available, i.e. "Mono Soft Debugger for iPhone"

Actual Result:

There is only one optin available, i.e. "Mono Soft Debugger for iPhone". Whether we have created a solution for iPhone, iPad, or Universal. Every time the same option is available.

Expected Result:

For iPhone type solution, all the options related to iPhone should appear, for iPad type solution all the options related to iPad should appear, and for Universal solution all the options should appear.

Environment:

Mac 10.7 (Lion)
MonoTouch 4.9.4
MonoDevelop 2.8
Comment 1 Mikayla Hutchinson [MSFT] 2011-10-03 08:02:49 UTC
In the context of a "device" build, that's the only option that's available. However, the name is a bit misleading. We should probably rename it to "Mono Soft Debugger for iOS" or "MonoTouch debugger".

It's a legacy name from before iPad existed, and project configuration platform names have the same problem. Unfortunately they're much less easy to fix.
Comment 2 Jatin 2011-10-03 11:06:22 UTC
Hi Michael, 

As per our observation this issue was related to environment configuration (X-Code was installed), however, after reconfirming it on another environment with X-code installed, all the above options are available under Run With, as per the test case please suggest if we can close this issue.

Regards,
Jatin
Comment 3 Mikayla Hutchinson [MSFT] 2011-10-03 11:14:18 UTC
Is the active configuration "Debug|iPhoneSimulator", or "Debug|iPhone"?
Comment 4 Jatin 2011-10-10 10:51:19 UTC
Hi Michael,

Previously I had verified with active configuration "Debug|iPhoneSimulator", and only One option, i.e. "Mono Soft Debugger for iPhone" was appearing. 

But now I have validated with MonoTouch 4.9.8 with Xcode 4.2 installed, and now for the same configuration all the 3 options are appearing, i.e.

1. Mono Soft Debugger for iPhone
2. iPhone Simulator 5.0
3. iPad SImulator 5.0

Thanks,
Jatin
Comment 5 Mikayla Hutchinson [MSFT] 2011-10-10 18:08:01 UTC
Ok, I'll close the bug until we can reproduce it with current versions and verify it's incorrect behaviour, since there are a couple of ways that menu could be empty correctly.